Bug 1280183 - Failed to switch Hosted Engine maintenance to Local and None via Hosted Engine TUI
Summary: Failed to switch Hosted Engine maintenance to Local and None via Hosted Engin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.1
: 3.6.1
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
: 1280180 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-11 06:21 UTC by Huijuan Zhao
Modified: 2016-03-09 14:42 UTC (History)
15 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:42:49 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
sosreport (9.94 MB, application/x-xz)
2015-11-11 06:34 UTC, Huijuan Zhao
no flags Details
log (9.46 MB, application/x-gzip)
2015-11-11 06:38 UTC, Huijuan Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 48468 master MERGED The maintenance dialog should reflect the current setting Never
oVirt gerrit 51000 ovirt-3.6 MERGED The maintenance dialog should reflect the current setting 2015-12-23 15:28:01 UTC

Description Huijuan Zhao 2015-11-11 06:21:03 UTC
Description:.
Failed to switch Hosted Engine maintenance to Local and None via Hosted Engine TUI

Version:
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

Test Steps:
1. RHEV-H installed successful.
2. Login RHEV-H, change to Hosted Engine page, Deploy Hosted Engine.
3. Click <Set Hosted Engine maintenance> on Hosted Engine page
4. Choose and enable Local level, click < Set >, and click <Set Hosted Engine maintenance> to check.
5. Choose and enable None level, click < Set >, and click <Set Hosted Engine maintenance> to check.

Actual Results
After step4, set Local Maintenance Level failed, it is still Global Maintenance Level.
After step5, set None Maintenance Level failed, it is still Global Maintenance Level.

Expected Results
After step4, set Local Maintenance Level successful, it should be Local Maintenance Level.
After step5, set None Maintenance Level successful, it should be None Maintenance Level.

Comment 1 Huijuan Zhao 2015-11-11 06:34:07 UTC
Created attachment 1092588 [details]
sosreport

Comment 2 Huijuan Zhao 2015-11-11 06:38:05 UTC
Created attachment 1092589 [details]
log

Comment 3 Huijuan Zhao 2015-11-12 06:49:33 UTC
After set Local or None level, check via < Hosted Engine VM status > show setup successful.  But check via < Set Hosted Engine maintenance >, the level is still Global, it should show current level configure.

Comment 5 Ryan Barry 2015-11-17 14:23:53 UTC
Yes, it's a duplicate.

I'll also reiterate that hosted-engine --vm-status (and the status in the TUI) may take up to half a minute to reflect the changed status for verifying the other bug.

hosted-engine --set-maintenance --mode=... sends a command to ovirt-ha-agent, which then does some processing before the status reflects the change.

*** This bug has been marked as a duplicate of bug 1280180 ***

Comment 6 Huijuan Zhao 2015-11-18 06:07:44 UTC
Hi Ryan,

I submitted twice as the log is too large and it shows not successful for the first time submission. So there are 2 same bugs now.

Please close Bug 1280180 DUPLICATE, and reopen Bug 1280183 which is downstream product and have log in attach.

Thanks.

Comment 7 Ryan Barry 2015-11-18 17:48:12 UTC
*** Bug 1280180 has been marked as a duplicate of this bug. ***

Comment 9 Huijuan Zhao 2015-12-08 07:28:36 UTC
Version:
rhev-hypervisor7-7.2-20151201.2.iso
ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev.noarch

Test Steps:
1. RHEV-H installed successful.
2. Login RHEV-H, change to Hosted Engine page, Deploy Hosted Engine.
3. Click <Set Hosted Engine maintenance> on Hosted Engine page
4. Choose and enable Local level, click < Set >, and click <Set Hosted Engine maintenance> to check.
5. Choose and enable None level, click < Set >, and click <Set Hosted Engine maintenance> to check.

Test Results
After step4, wait for half a minute, set Local Maintenance Level successful.
After step5, wait for half a minute, set None Maintenance Level successful.

So this bug is fixed on rhev-hypervisor7-7.2-20151201.2.iso, I will change the status to verified.

Comment 13 errata-xmlrpc 2016-03-09 14:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.