Bug 1280185 - It should not restart the TUI to check Hosted Engine status after HE deployed yet
It should not restart the TUI to check Hosted Engine status after HE deployed...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity high
: ovirt-3.6.1
: 3.6.0
Assigned To: Ryan Barry
Ying Cui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 01:29 EST by Ying Cui
Modified: 2016-03-09 09:43 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:43:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
varlog.tar.bz2 (10.83 MB, application/x-gzip)
2015-11-11 02:04 EST, Ying Cui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48508 master MERGED Refresh the status of the engine every time the UI is reloaded Never
oVirt gerrit 48977 ovirt-3.6 MERGED Refresh the status of the engine every time the UI is reloaded Never

  None (edit)
Description Ying Cui 2015-11-11 01:29:05 EST
Description of problem:
Hosted Engine is deployed successful on RHEVH via ttyS1 console or ssh access yet, but HE TUI still display "not configured". Here the user must log off TUI firstly, and relogin RHEV-H TUI, then check Hosted Engine TUI, here display "configured".

Version:
# rpm -qa ovirt-node ovirt-node-plugin-hosted-engine
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

Test Steps:
1. Clean installed RHEV-H 7.2 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Navigate to "Hosted Engine" TUI.
5. Deploy Hosted Engine
6. Set URL on "Engine ISO/OVA URL for download"
7. Click on "Deploy"
8. RHEV-H is UP on HE-VM, the hosted-engine deployment process is done yet. Here back to RHEV-H TUI.
9. Check Hosted Engine Status, still display "Not configured"
10. log off RHEV-H TUI
11. relogin RHEV-H TUI
12. Recheck Hosted Engine TUI. here display Hosted Engine: Configured

Actual Result:
Step 9,Hosted Engine status display "Not configured"

Expected Result:
After Hosted engine setup successful on RHEV-H, then Hosted Engine TUI should display as configured, no need to let user logoff and relogin to restart TUI than check the HE status on TUI.
Comment 1 Ying Cui 2015-11-11 02:04 EST
Created attachment 1092592 [details]
varlog.tar.bz2
Comment 2 Ying Cui 2015-11-11 03:45:33 EST
Another flow also regarding to restarting the TUI to check HE-Engine Status on Hosted Engine TUI.

After Hosted engine deployment, F2 to shell.

# hosted-engine --vm-shutdown

After HE-VM shutdown, back to Hosted Engine TUI, Here still display Engine is running. We need to logoff and relogin to restart the TUI, then check the Engine is not running.
Comment 3 Ryan Barry 2015-11-12 09:50:13 EST
Patch submitted -- just be aware that you'll need to switch pages in the TUI for it to appear, since a reload isn't invoked after returning from the rescue shell, and I'd rather not put a timer in the page which reloads for a variety of reasons.

Also, like everything else HE related, for verification, it may take some time before the status is reflected. If "hosted-engine --vm-status" (or the VM status dialog) shows it as down, the TUI will reflect it once you change pages and back, but the shutdown can take minutes...
Comment 4 Ying Cui 2015-11-16 08:56:05 EST
Ryan, For this bug we need release note for rhevh 3.6 beta 1. Thanks.
Comment 6 Ying Cui 2015-12-24 07:28:51 EST
Verified this bug on the following rhevh version.

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151221.1.el7ev)
# rpm -qa ovirt-node ovirt-node-plugin-hosted-engine
ovirt-node-plugin-hosted-engine-0.3.0-4.el7ev.noarch
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Test steps:
1. Clean installed RHEV-H 7.2 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Navigate to "Hosted Engine" TUI.
5. Deploy Hosted Engine
6. Set URL on "Engine ISO/OVA URL for download"
7. Click on "Deploy"
8. RHEV-H is UP on HE-VM, the hosted-engine deployment process is done, then back to RHEV-H TUI.


Result: 
Here take some times(about 10mins) before the status is reflected, you can switch pages in the TUI, no need to logoff and relogin to restart TUI than check the HE status on TUI.
Comment 8 errata-xmlrpc 2016-03-09 09:43:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.