Bug 1280215 - RHN status always show success even if the registration was failed
RHN status always show success even if the registration was failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.2
: ---
Assigned To: Ryan Barry
cshao
:
: 1282698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 03:48 EST by cshao
Modified: 2016-03-09 09:43 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.6.1-1.0.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_issue.tar.gz (649.67 KB, application/x-gzip)
2015-11-11 03:48 EST, cshao
no flags Details
failed (22.95 KB, image/png)
2015-11-11 03:53 EST, cshao
no flags Details
always show success (42.54 KB, image/png)
2015-11-11 03:53 EST, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48515 master MERGED Be smarter about failed RHNSM/Satellite registrations Never
oVirt gerrit 49262 ovirt-3.6 MERGED Be smarter about failed RHNSM/Satellite registrations Never
oVirt gerrit 50542 master MERGED subscription-manager can return 0 when not registered... 2015-12-22 07:03 EST
oVirt gerrit 50917 ovirt-3.6 MERGED subscription-manager can return 0 when not registered... 2015-12-22 10:01 EST

  None (edit)
Description cshao 2015-11-11 03:48:10 EST
Created attachment 1092613 [details]
rhn_issue.tar.gz

Description of problem:
RHN status always show success even if the registration was failed. And the same issue with Satellite/SAM.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151104.0
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
subscription-manager-1.15.9-15.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64
vdsm-4.17.10.1-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H 7.2
2. Go to "RHN Registration" page, register to RHN/Satellite/SAM with incorrect info.
3. Check RHN status in TUI.

Actual results:
RHN status always show success even if the registration was failed

Expected results:
RHN can show correct status.

Additional info:
Comment 1 cshao 2015-11-11 03:53 EST
Created attachment 1092616 [details]
failed
Comment 2 cshao 2015-11-11 03:53 EST
Created attachment 1092617 [details]
always show success
Comment 3 Ryan Barry 2015-11-17 09:20:47 EST
*** Bug 1282698 has been marked as a duplicate of this bug. ***
Comment 5 cshao 2015-12-15 02:36:21 EST
Test version:
rhev-hypervisor7-7.2-20151210.1
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Test steps:
1. Install RHEV-H 7.2 latest build
2. Go to "RHN Registration" page, register to RHN with incorrect info.
3. Check RHN status in TUI.

Actual results:
1. pop-up: registration failed 
2. But in TUI, Registration Status still show as "RHN"

The current status shouldn't show as RHN due to the failed registration.

So I have to assigned this bug.
Comment 6 cshao 2015-12-29 02:05:33 EST
Test version:
RHEV-H 7.2-20151221.1.el7ev
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Got the same issue with #c5, so I have tp assigned this bug again.

Test steps:
1. Install RHEV-H 7.2 latest build
2. Go to "RHN Registration" page, register to RHN with incorrect info.
3. Check RHN status in TUI.

Actual results:
1. pop-up: registration failed 
2. But in TUI, Registration Status still show as "RHN"

The current status shouldn't show as RHN due to the failed registration.
Comment 11 errata-xmlrpc 2016-03-09 09:43:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.