Bug 1282698 - RHEV-H shown as registered after auto-install, even if no registration was requested
RHEV-H shown as registered after auto-install, even if no registration was re...
Status: CLOSED DUPLICATE of bug 1280215
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity unspecified
: ovirt-3.6.1
: 3.6.0
Assigned To: Ryan Barry
Chaofeng Wu
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 02:22 EST by Chaofeng Wu
Modified: 2016-02-10 14:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 09:20:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHN page screenshot (10.44 KB, image/png)
2015-11-17 02:40 EST, Chaofeng Wu
no flags Details
/var/log (410.37 KB, application/x-gzip)
2015-11-17 02:41 EST, Chaofeng Wu
no flags Details

  None (edit)
Description Chaofeng Wu 2015-11-17 02:22:47 EST
Description of problem:
Auto install RHEV-H, after system install successful, login to RHEV-H, navigate to RHN Registration page, the registration status is RHN. The RHN Registration page should not show the system already registered, we do not add the RHN registration related parameters during auto install.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151112.1.iso
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Auto install rhevh with the parameters:
   BOOTIF=eth0 storage_init=/dev/vda adminpw=prfqPTTTRUVLc firstboot

Actual results:	
After step1, on RHN Registration page the "Registration Status" is RHN.

Expected results:
After step1, on RHN Registration page the message should be "RHN Registration is required only if you wish to use Red Hat Enterprise Linux ..."

Additional info:
[root@localhost ~]# cat /var/log/messages | grep storage_init
Nov 17 06:23:52 dhcp-10-150 kernel: Command line: initrd=initrd0.img root=live:CDLABEL=rhev-hypervisor7-7.2-20151112.1 rootfstype=auto ro rd.live.image rd.live.check crashkernel=256M rd_NO_MULTIPATH rootflags=ro elevator=deadline install quiet max_loop=256 rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOTIF=eth0 storage_init=/dev/vda adminpw=prfqPTTTRUVLc firstboot BOOT_IMAGE=vmlinuz0 

[root@localhost ~]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Unknown

[root@localhost ~]# subscription-manager list

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Virtualization
Product ID:     150
Version:        3.6
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         
Ends:
Comment 1 Chaofeng Wu 2015-11-17 02:40 EST
Created attachment 1095230 [details]
RHN page screenshot
Comment 2 Chaofeng Wu 2015-11-17 02:41 EST
Created attachment 1095231 [details]
/var/log
Comment 3 Fabian Deutsch 2015-11-17 02:48:39 EST
Is the TUI only showing that the system is registered or was the system really registered?
Comment 4 Ryan Barry 2015-11-17 09:20:47 EST
It's a cosmetic issue. The system is not registered.

*** This bug has been marked as a duplicate of bug 1280215 ***

Note You need to log in before you can comment on or make changes to this bug.