Bug 128031 - Upgrade from FC2 to FC3T1 Exception on SELinux
Upgrade from FC2 to FC3T1 Exception on SELinux
Status: CLOSED DUPLICATE of bug 127713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 11:15 EDT by Chris Schamper
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Schamper 2004-07-16 11:15:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Opon upgrading from FC2 to FC3T1, anaconda throws an exception as per
described below. Error:

OSError [Errno 17] File Exists: '/mnt/sysimage/selinux'

I would include the rest of the traceback, except the "Save to floppy"
is non-functional. The Second to last line is:

File "/usr/lib/anaconda/packages.py", line 737, in doPreInstall
  os.mkdir(instPath + "/selinux")

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Find / Install FC2
2. Choose upgrade option from anaconda during FC3T1 install
3. Click Next on "About to Upgrade" screen
4. Hit Continue for required media
5. Observe Exception
    

Actual Results:  Anaconda throws an exception

Expected Results:  Expected normal install.

Additional info:
Comment 1 Paul Nasrat 2004-07-16 11:33:35 EDT
Duplicate. FYI Save to Floppy issue also fixed in rawhide



*** This bug has been marked as a duplicate of 127713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.