Bug 1280333 - include ACFS filesystem number in coreutils (0x61636673)
Summary: include ACFS filesystem number in coreutils (0x61636673)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils
Version: 6.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Branislav Blaškovič
Milan Navratil
URL:
Whiteboard:
Depends On:
Blocks: 1280357
TreeView+ depends on / blocked
 
Reported: 2015-11-11 13:51 UTC by Harald Klein
Modified: 2019-10-10 10:28 UTC (History)
3 users (show)

Fixed In Version: coreutils-8.4-40.el6
Doc Type: Release Note
Doc Text:
The Oracle ACFS is now included among known file systems Previously, the Oracle ASM Cluster file system (ACFS) was not listed among known file systems for the *stat* and *tail* utilities. As a consequence, the *tail* utility printed an error message stating that the file system was not recognized. ACFS has been added to the list of known file systems, and the error message no longer appears in the described situation. In addition, other file systems recognized by upstream have been added to the list of known file systems as well, namely `acfs`, `bpf_fs`, `btrfs_test`, `configfs`, `efivarfs`, `exofs`, `f2fs`, `hfs+`, `hfsx`, `hostfs`, `ibrix`, `logfs`, `nsfs`, `overlayfs`, `smackfs`, `snfs`, `tracefs`, and `ubifs`.
Clone Of:
: 1280357 (view as bug list)
Environment:
Last Closed: 2016-05-11 00:31:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0906 0 normal SHIPPED_LIVE coreutils bug fix and enhancement update 2016-05-10 22:51:30 UTC

Description Harald Klein 2015-11-11 13:51:25 UTC
Description of problem:

the filesystem number from ACFS (0x61636673) is not listed in coreutils on RHEL6

Version-Release number of selected component (if applicable):

coreutils 

How reproducible:

run e.g. tail on a file residing on ACFS

Steps to Reproduce:
1. # tail -f test.log

Actual results:

hoge
fuga
tail: unrecognized file system type 0x61636673 for `test.log'. Reverting to 
polling.

Expected results:

known filesystem type

Comment 1 Ondrej Vasik 2015-11-11 15:13:25 UTC
As an upstream report reference - debbugs.gnu.org/cgi/bugreport.cgi?bug=21876 ... with http://debbugs.gnu.org/cgi/bugreport.cgi?msg=10;filename=stat-new-fs-types.patch;att=1;bug=21876 as a patch by Pádraig Brady. Thanks Pádraig.

Comment 2 Pádraig Brady 2015-11-11 15:15:26 UTC
Note this file system is out of kernel tree.
Also newer versions of tail will not warn about this.
In any case this definition has been added to upstream at:
http://git.sv.gnu.org/gitweb/?p=coreutils.git;a=commitdiff;h=v8.24-83-g0daa359

Comment 9 Branislav Blaškovič 2016-03-29 12:58:43 UTC
Patch coreutils-8.4-tailstatnewfs2.patch is present in coreutils-8.4-42.el6.
This patch introduces all new FS recognized by upstream.

Comment 11 errata-xmlrpc 2016-05-11 00:31:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0906.html


Note You need to log in before you can comment on or make changes to this bug.