Bug 1280357 - include ACFS filesystem number in coreutils (0x61636673)
include ACFS filesystem number in coreutils (0x61636673)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: coreutils (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
Jakub Prokes
Petr Bokoc
:
Depends On: 1280333
Blocks: 1203710 1313485 1289025 1295829
  Show dependency treegraph
 
Reported: 2015-11-11 09:37 EST by Ondrej Vasik
Modified: 2016-11-04 03:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: coreutils-8.22-17.el7
Doc Type: Enhancement
Doc Text:
The Oracle ACFS is now included among known file systems Previously, the Oracle ASM Cluster file system (ACFS) was not listed among known file systems for the *stat* and *tail* utilities. As a consequence, the *tail* utility printed an error message stating that the file system was not recognized. ACFS has been added to the list of known file systems, and the error message no longer appears in the described situation. In addition, other file systems recognized by upstream have been added to the list of known file systems as well, namely *bpf_fs*, *btrfs_test*, *configfs*, *hfs+*, *hfsx*, *ibrix*, *logfs*, *m1fs*, *nsfs*, *overlayfs*, *prl_fs*, and *tracefs*.
Story Points: ---
Clone Of: 1280333
Environment:
Last Closed: 2016-11-04 03:39:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Vasik 2015-11-11 09:37:07 EST
+++ This bug was initially created as a clone of Bug #1280333 +++

Description of problem:

the filesystem number from ACFS (0x61636673) is not listed in coreutils on RHEL6

Version-Release number of selected component (if applicable):

coreutils 

How reproducible:

run e.g. tail on a file residing on ACFS

Steps to Reproduce:
1. # tail -f test.log

Actual results:

hoge
fuga
tail: unrecognized file system type 0x61636673 for `test.log'. Reverting to 
polling.

Expected results:

known filesystem type
Comment 2 Ondrej Vasik 2015-11-11 10:13:16 EST
As an upstream report reference - debbugs.gnu.org/cgi/bugreport.cgi?bug=21876 ... with http://debbugs.gnu.org/cgi/bugreport.cgi?msg=10;filename=stat-new-fs-types.patch;att=1;bug=21876 as a patch by Pádraig Brady. Thanks Pádraig.
Comment 12 errata-xmlrpc 2016-11-04 03:39:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2497.html

Note You need to log in before you can comment on or make changes to this bug.