Bug 1280353 - Failed data uploads cause data to be left in /var/tmp
Failed data uploads cause data to be left in /var/tmp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-access-insights (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jcrafts
Martin Kyral
:
Depends On:
Blocks: 1277547
  Show dependency treegraph
 
Reported: 2015-11-11 09:33 EST by Andy Grimm
Modified: 2016-11-07 22:48 EST (History)
5 users (show)

See Also:
Fixed In Version: redhat-access-insights-1.0.7-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1295925 (view as bug list)
Environment:
Last Closed: 2016-05-10 20:43:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2015-11-11 09:33:16 EST
Across our environment, we see occasional failures to upload data to redhat-access-insights for various reasons.  The problem is that when such failures occur, temp directories are left in /var/tmp.  I have found some node with dozens of these which have accumulated over several months.

We can tmpwatch the directory, but since the top-level directory doesn't have a special prefix, it's hard to specifically target directories generated by RHAI.

So I'm suggesting two things here:

1) When an upload fails, remove the temp dir (people might want a boolean config option for this)
2) name the temp dir with a prefix, maybe "rhai-", so we can more easily find and delete these.
Comment 3 Martin Kyral 2016-03-10 09:54:18 EST
Hi,

please, could you share the information on

1) how was this BZ fixed and
2) how to test it?

Thanks!
Comment 4 jcrafts 2016-03-10 10:06:43 EST
Hi Martin,

This BZ was fixed by

1) Always deleting the archive after upload
2) An exit handler that will delete temporary files if the upload is interrupted

Both, will, however retain the archive if "--keep-archive" is specified.

Path 1 can be tested by running a normal upload, path 2 can be tested by canceling the upload with a Ctrl+C interrupt.
Comment 7 errata-xmlrpc 2016-05-10 20:43:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0928.html

Note You need to log in before you can comment on or make changes to this bug.