Bug 1280414 - Users unable to change password from Horizon dashboard
Users unable to change password from Horizon dashboard
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Ido Ovadia
: Regression
: 1284267 (view as bug list)
Depends On:
Blocks: 1290377 1339866
  Show dependency treegraph
 
Reported: 2015-11-11 12:06 EST by David Hill
Modified: 2016-10-14 16:53 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 16:53:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2015-11-11 12:06:29 EST
Description of problem:
Users unable to change password from Horizon dashboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install director 
2. Create users
3. Connect to horizon with one of the user
4. Try to change the password

Actual results:
Fails to change the password

Expected results:
The password should be changed

Additional info:
This is due to the internalURL not being properly set when keystone is bootstrapped at installation time.  I'll attach more private details in the comments below.   The internalURL seems to be using an IP of the undercloud and haproxy is not binging on the port 5000 of the IP shown in endpoint list.   We've looked at the hieradata information it seems to be ok so I would suspect that the issue happened when the bootstrap node configured keystone .
Comment 9 Matthias Runge 2015-11-24 08:53:01 EST
*** Bug 1284267 has been marked as a duplicate of this bug. ***
Comment 16 Marius Cornea 2016-01-27 17:32:20 EST
I checked this issue on a 7.3 deployment and it seems that it's fixed:

Service: identity
+-------------+----------------------------------+
|   Property  |              Value               |
+-------------+----------------------------------+
|   adminURL  |   http://192.0.2.15:35357/v2.0   |
|      id     | 0342b54b22f34607831003afeabc0f3e |
| internalURL |  http://172.16.20.10:5000/v2.0   |
|  publicURL  |  http://172.16.23.10:5000/v2.0   |
|    region   |            regionOne             |
+-------------+----------------------------------+

[heat-admin@overcloud-controller-0 ~]$ curl http://172.16.20.10:5000/v2.0
{"version": {"status": "stable", "updated": "2014-04-17T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v2.0+json"}], "id": "v2.0", "links": [{"href": "http://172.16.23.10:5000/v2.0/", "rel": "self"}, {"href": "http://docs.openstack.org/", "type": "text/html", "rel": "describedby"}]}}

I think this was fixed by:
https://review.openstack.org/#/c/250875/
Comment 18 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 20 Ola Pavlenko 2016-10-05 11:42:11 EDT
Hi Ido,

Could you please check whether the bug is fixed in 10?

Thanks
Comment 21 Ido Ovadia 2016-10-06 10:40:32 EDT
(In reply to Ola Pavlenko from comment #20)
> Hi Ido,
> 
> Could you please check whether the bug is fixed in 10?
> 
> Thanks

This bug didn't reproduced on RHOS 10
Comment 22 Jason E. Rist 2016-10-14 16:53:45 EDT
Closing as this can't be reproduced for RHOS 10

Note You need to log in before you can comment on or make changes to this bug.