Bug 1280432 - External ceph sample config should use parameter_defaults
External ceph sample config should use parameter_defaults
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Ben Nemec
Yogev Rabl
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 12:46 EST by Ben Nemec
Modified: 2016-04-07 17:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-10.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:42:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Nemec 2015-11-11 12:46:48 EST
Description of problem: We merged an early version of the external ceph patch in RHOS 7, but the upstream review subsequently determined that the parameters involved should not be exposed as top-level parameters and instead should be set using parameter_defaults.  Fortunately this will work fine for the version of the patch we merged, but we need to update our sample environment in environments/puppet-ceph-external.yaml to reflect the change so users are able to upgrade seamlessly from 7 to 8 (which will have the upstream version of the change).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 Giulio Fidente 2015-11-20 08:00:44 EST
Or to pick the latest version of https://review.openstack.org/#/c/212664/ if it is for 8 only.
Comment 7 Yogev Rabl 2016-03-02 04:08:26 EST
Verified on 
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
Comment 8 Ben Nemec 2016-03-07 10:20:57 EST
The documentation changes related to this are being tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1280431
Comment 10 errata-xmlrpc 2016-04-07 17:42:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.