Bug 1280503 - Registry docs: ImageStreams do not support 3rd party registries that require authentication
Registry docs: ImageStreams do not support 3rd party registries that require ...
Status: CLOSED DUPLICATE of bug 1337330
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 17:46 EST by Josep 'Pep' Turro Mauri
Modified: 2016-05-29 21:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-29 21:12:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josep 'Pep' Turro Mauri 2015-11-11 17:46:26 EST
Document URL: 
https://docs.openshift.com/enterprise/3.0/architecture/infrastructure_components/image_registry.html#authentication

Section Number and Name:

Architecture > Image Registry > Third Party Registries > Authentication

Describe the issue:

The section describes integration with 3rd party registries, and it seems to imply that ImageStreams work with 3rd party registries (with the caveat of manual import-image) even if they require authentication.

At this time, this is not the case though, see Bug 1271328: ImageStreams do not work with external registries that require authentication.

Suggestions for improvement:

In the Authentication section, explain that ImageStreams do not work. It can be possible to pull images from a registry by referencing them directly (not via an ImageStream) and providing credentials via a secret; this might also be worth mentioning as an alternative (with further reduced functionality) but I have not confirmed how it works.

Additional information:

The section would change again once changes for bug 1271328 are implemented.
Comment 1 Vikram Goyal 2016-05-29 21:12:06 EDT

*** This bug has been marked as a duplicate of bug 1337330 ***

Note You need to log in before you can comment on or make changes to this bug.