Bug 128053 - the active-filter outbound option for ppp doesn't work
Summary: the active-filter outbound option for ppp doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
: 130648 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-16 20:12 UTC by Bruno Wolff III
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 09:40:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2004-07-16 20:12:53 UTC
Description of problem:When one tries to activate a ppp device and
the 'active-filter outbound' option has been configured the activation
fails with the error message: pppd: error in active-filter expression: inbound/outbound not supported on
Version-Release number of selected component (if applicable):linktype 0


How reproducible:It happens all of the time


Steps to Reproduce:
1.Use network config to add the option 'activate-filter outbound' to a dialup ppp device
2.Attempt to activate the device
3.
  
Actual results:The activation fails


Expected results:The activation should succeed


Additional info:I am using FC2 with the following development rpms installed:
ppp-2.4.2-3.1
libpcap-0.8.3-4
kernel-2.6.7-1.471

Comment 1 Bruno Wolff III 2004-07-17 14:31:38 UTC
I tried this with kernel-2.6.7-1.492 and am seeing the same problem.
I am going to look at the pppd SRPM and see if I can find a work
around. If it is really a kernel problem, then I am not going
to be able to do much.

Comment 2 Thomas Woerner 2004-08-23 13:23:22 UTC
*** Bug 130648 has been marked as a duplicate of this bug. ***

Comment 3 Enrico Scholz 2004-08-24 18:12:53 UTC
This is caused by recent libpcap which does not support
outbound/inbound for PPP linktypes anymore.

SuSE seems to have a fix by generating a dummy DLT_LINUX_SLL packet
(which supports these qualifiers). See ppp-2.4.2-libpcap.diff in
http://ftpl.tu-chemnitz.de/pub/linux/suse/suse_update/9.1/rpm/src/ppp-2.4.2-39.3.src.rpm

This patch was used by Debian for a short time also, but they went
back to libpcap-0.7 (which supports outbound/inbound for DLT_PPP).

Comment 4 Thomas Woerner 2004-08-31 10:13:05 UTC
Can you please test this with kernel 2.6.8-1.533?
There is a fix in this kernel for ppp.

Comment 5 Enrico Scholz 2004-08-31 10:20:06 UTC
This is probably *not* a kernel issue. As said, support for 'outbound'
was be removed from libpcap-0.8.

You can test it yourself by executing 

| pppd active-filter outbound

Comment 6 Thomas Woerner 2004-09-16 09:40:45 UTC
Fixed in rawhide in rpm ppp-2.4.2-5 or newer.


Note You need to log in before you can comment on or make changes to this bug.