Bug 1281296 - You need to pass puppet-pacemaker.yaml environment file for Pacemaker to be deployed as cluster resource manager
You need to pass puppet-pacemaker.yaml environment file for Pacemaker to be d...
Status: CLOSED DUPLICATE of bug 1281613
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Hugh Brock
Marius Cornea
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 04:18 EST by Marius Cornea
Modified: 2016-03-21 07:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 13:42:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-12 04:18:06 EST
Description of problem:
With OSP8 director you need to pass /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml to the deploy command for Pacemaker to be deployed as cluster resource manager on the overcloud controller. With OSP7 this used to be the default for bot HA and non-HA deployments.

Version-Release number of selected component (if applicable):
openstack-tripleo-common-0.0.2-3.el7ost.noarch
python-tripleoclient-0.0.11-5.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-1.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud without passing puppet-pacemaker.yaml
2. Run pcs status on controller nodes

Actual results:
Pacemaker is not running

Expected results:
The installer sets up the cluster resources. 

Additional info:
Comment 5 Mike Burns 2016-02-25 13:42:32 EST

*** This bug has been marked as a duplicate of bug 1281613 ***

Note You need to log in before you can comment on or make changes to this bug.