Bug 1281613 - rhel-osp-director: 8.0 - the overcloud deployment fails because pacemaker isn't the default
rhel-osp-director: 8.0 - the overcloud deployment fails because pacemaker isn...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Marios Andreou
Alexander Chuzhoy
:
: 1280469 1281296 (view as bug list)
Depends On:
Blocks: 1261979 1280469 1337537
  Show dependency treegraph
 
Reported: 2015-11-12 18:20 EST by Alexander Chuzhoy
Modified: 2016-05-19 08:11 EDT (History)
25 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-9.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1337537 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
os-collect-config messages (78.43 KB, application/x-gzip)
2015-11-12 18:21 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-11-12 18:20:45 EST
rhel-osp-director: 8.0 - the overcloud deployment fails; puppet errors during glance configuration.



Environment:
python-glance-11.0.0-1.el7ost.noarch
python-glanceclient-1.1.0-1.el7ost.noarch
puppet-3.6.2-2.el7.noarch
openstack-puppet-modules-7.0.1-1.el7ost.noarch
openstack-glance-11.0.0-1.el7ost.noarch
python-glance-store-0.9.1-1.el7ost.noarch


Steps to reproduce:

 Attempt to deploy the overcloud with selinux set to permissive.

Result:
The deployment fails:
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
Stack failed with status: Resource CREATE failed: resources.ControllerOvercloudServicesDeployment_Step4: resources.ControllerNodesPostDeployment.Error: resources[0]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6
Heat Stack create failed.


Lots of puppet errors related to glance in the os-collect-config journal (attached).


Expected result:
No glance errors.
Comment 2 Alexander Chuzhoy 2015-11-12 18:21 EST
Created attachment 1093491 [details]
os-collect-config messages
Comment 3 Alexander Chuzhoy 2015-11-16 10:48:29 EST
Was able to deploy the overcloud without even setting selinux to permissive.
Had to explicitely enable pacemaker with "-e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml".
Comment 5 Giulio Fidente 2015-12-09 14:07:44 EST
*** Bug 1280469 has been marked as a duplicate of this bug. ***
Comment 13 Alexander Chuzhoy 2016-02-24 14:56:32 EST
Verified:

Environment:
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch


Deployed 8.0 without pacemaker:
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT \
-e $THT/environments/network-isolation.yaml \
-e /home/stack/network-environment.yaml \
--control-scale 3 \
--compute-scale 2 \
--neutron-disable-tunneling \
--neutron-network-type vlan \
--neutron-network-vlan-ranges datacentre:<range> \
--neutron-bridge-mappings datacentre:br-ex \
--ntp-server clock.redhat.com \
--timeout 180

Upon successful deployment, logged in to a controller and ran "pcs status":
All services are started and:
PCSD Status:
  overcloud-controller-0: Online
  overcloud-controller-1: Online
  overcloud-controller-2: Online

Daemon Status:
  corosync: active/enabled
  pacemaker: active/enabled
  pcsd: active/enabled
Comment 14 Mike Burns 2016-02-25 13:42:32 EST
*** Bug 1281296 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2016-04-07 17:42:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.