Bug 1281338 - VM failed to run when Replacing/reducing host CPU family or architecture.
VM failed to run when Replacing/reducing host CPU family or architecture.
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.5.6.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Ilanit Stein
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 05:43 EST by Nisim Simsolo
Modified: 2015-11-12 07:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 07:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (2.31 MB, text/plain)
2015-11-12 06:35 EST, Nisim Simsolo
no flags Details
vdsm log (10.11 MB, text/plain)
2015-11-12 06:38 EST, Nisim Simsolo
no flags Details

  None (edit)
Description Nisim Simsolo 2015-11-12 05:43:58 EST
Description of problem:
When removing host from cluster and adding host with different CPU architecture or oldest CPU family, VM CPU type is still equal to removed CPU type instead of being changed to the new host CPU type.
When this issue occurs, VM cannot be run as long as there is value in VM OS type.

Bug is relevant for host replacement to an older CPU family and for changing host CPU type from Intel to AMD and vice versa.

Version-Release number of selected component (if applicable):
rhevm-3.5.6.2-0.1.el6ev (vt18.2)
qemu-kvm-rhev-0.12.1.2-2.479.el6_7.2.x86_64
sanlock-2.8-2.el6_5.x86_64
vdsm-4.16.29-1.el6ev.x86_64
libvirt-client-0.10.2-54.el6_7.2.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Add AMD host to cluster and create Windows 10 VM on it (select VM OS type "Windows 10").
2. Power off VM, remove AMD host and add Intel host to cluster.
3. Try to run VM.

Actual results:
VM failed to run with an error message:
The guest OS doesn't support the following CPUs: opteron_g4, opteron_g3...

(this error message is relevant for a different bug (https://bugzilla.redhat.com/show_bug.cgi?id=1277214), but it also shows that VM CPU type does not changed to the new host CPU type.

Observing engine DB shows that cPU family remains AMD:
-bash-4.1$ psql engine postgres  -c 'select vm_name,vds_group_cpu_name from vms'
    vm_name     | vds_group_cpu_name  
----------------+---------------------
 win7_from_temp | Intel Conroe Family
 win10          | AMD Opteron G4
(2 rows)


Expected results:
VM CPU type should be cleared when removing host from cluster.

Additional info:
VDSM and engine logs attached.
Bug set to medium, because the usecase for replacing CPU architecture from AMD to Intel or vice versa or reducing to an older CPU family is rare.
Comment 1 Nisim Simsolo 2015-11-12 06:35 EST
Created attachment 1093170 [details]
engine log
Comment 2 Nisim Simsolo 2015-11-12 06:38 EST
Created attachment 1093173 [details]
vdsm log
Comment 3 Nisim Simsolo 2015-11-12 07:46:30 EST
Closed as not a bug. some issues with my setup leads to misunderstanding of this behavior.

Note You need to log in before you can comment on or make changes to this bug.