Bug 1281438 - Spice: opening spice-html5 console causes QEMU crash (spice related assertion?)
Spice: opening spice-html5 console causes QEMU crash (spice related assertion?)
Status: CLOSED DUPLICATE of bug 1281442
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: pre-dev-freeze
: 7.3
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
spice
:
Depends On: 1281442
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 09:31 EST by Jiri Belka
Modified: 2015-11-24 10:26 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 10:26:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-11-12 09:31:07 EST
Description of problem:

opening spice-html5 console of Windows 10 makes the VM go down.

~~~
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name w10 -S -machine pc-i440fx-rhel7.2.0,accel=kvm,usb=off -cpu SandyBridge,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff -m size=2097152k,slots=16,maxmem=20971520k -realtime mlock=off -smp 2,maxcpus=16,sockets=16,cores=1,threads=1 -numa node,nodeid=0,cpus=0-1,mem=2048 -uuid 6b2cddc7-bc08-402b-aa92-df10b47116d8 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=7.2-7.el7,serial=4C4C4544-0058-3410-8058-C2C04F38354A,uuid=6b2cddc7-bc08-402b-aa92-df10b47116d8 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-w10/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2015-11-12T14:22:41,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x5 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x6 -drive file=/rhev/data-center/mnt/10.34.63.204:_home_iso_shared/0c78b4d6-ba00-4d3e-9f9f-65c7d5899d71/images/11111111-1111-1111-1111-111111111111/en_windows_10_enterprise_x86_dvd_6851156.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -drive file=/rhev/data-center/00000001-0001-0001-0001-0000000003e1/2834fba3-6200-489d-9868-7b8c162749ca/images/f59a075c-8442-44d8-8796-766e27452afe/9c5b1fc9-0dbd-4cae-9b02-92deabc22d15,if=none,id=drive-virtio-disk0,format=raw,serial=f59a075c-8442-44d8-8796-766e27452afe,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=2 -netdev tap,fd=29,id=hostnet0,vhost=on,vhostfd=30 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:e7:3f:07,bus=pci.0,addr=0x3,bootindex=3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/6b2cddc7-bc08-402b-aa92-df10b47116d8.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/6b2cddc7-bc08-402b-aa92-df10b47116d8.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=5902,tls-port=5903,addr=10.34.63.223,x509-dir=/etc/pki/vdsm/libvirt-spice,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=33554432,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -msg timestamp=on
2015-11-12T14:22:41.827041Z qemu-kvm: warning: CPU(s) not present in any NUMA nodes: 2 3 4 5 6 7 8 9 10 11 12 13 14 15
2015-11-12T14:22:41.827122Z qemu-kvm: warning: All CPU(s) up to maxcpus should be described in NUMA config
main_channel_link: add main channel client
main_channel_handle_parsed: net test: latency 6.918000 ms, bitrate 74938709 bps (71.467122 Mbps)
((null):16772): Spice-ERROR **: reds.c:1485:reds_send_link_ack: assertion `link->link_mess->channel_type == SPICE_CHANNEL_MAIN' failed
2015-11-12 14:23:11.345+0000: shutting down
~~~

Version-Release number of selected component (if applicable):
spice-html5-0.1.6-2.el6.noarch
rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch
firefox-41.0.2p0

How reproducible:
100%

Steps to Reproduce:
1. boot Windows 10 VM from install iso (I have 32bit version)
2. open spice-html5 console
3. check VM status

Actual results:
VM is down

Expected results:
should be running

Additional info:
- normal (native) spice console of course does _NOT_ causes the VM shutdown
- windows 8.1 64bit is ok via spice-html5 console
Comment 1 Yaniv Kaul 2015-11-13 05:47:37 EST
Clearly a spice / qemu bug. 
Please move to correct component.
Comment 2 Jiri Belka 2015-11-13 05:51:20 EST
This BZ is here to know status for Windows 10, thus it's a tracking BZ. See depends on box. (This was OK by mskrivanek@.)
Comment 3 Yaniv Kaul 2015-11-13 06:37:35 EST
That's not how tracker bugs are opened.
Comment 4 Yaniv Kaul 2015-11-13 06:39:57 EST
And of course,  a tech preview feature (spice-html5) cannot block another feature, such as win10 support.
Comment 5 Jiri Belka 2015-11-13 06:48:23 EST
Rephrasing a comment from Michal yesterday: "...this bug bypasses our roles. One can define a role without permission to poweroff/shutdown a VM and the user could achieve this just while opening spice-html5 console. ...Please change it from Low to High..."
Comment 6 Yaniv Kaul 2015-11-13 14:16:52 EST
(In reply to Jiri Belka from comment #5)
> Rephrasing a comment from Michal yesterday: "...this bug bypasses our roles.
> One can define a role without permission to poweroff/shutdown a VM and the
> user could achieve this just while opening spice-html5 console. ...Please
> change it from Low to High..."

So open a different bug on the issue. Your initial description has nothing to do with the above note (and is it related to win10?)
Comment 7 Michal Skrivanek 2015-11-14 09:52:51 EST
Yaniv, I don't think this component is used by anyone. bug 1281442 is the "different bug" opened on rhel, and it's making progress. 
I would suggest/propose to keep this as "virt" bug for my tracking should we need to do a different workaround or require new qemu version
Comment 8 Yaniv Kaul 2015-11-14 13:13:26 EST
If it's not used (I asked in rhev-devel some time ago why do we need it)  -  remove it. 
It's not a virt bug. 
If you need a newer qemu release,  open a 'depend on qemu release' bug and make it depends on the qemu bug.
Comment 9 Karen Noel 2015-11-24 08:56:46 EST
(In reply to Yaniv Kaul from comment #8)
> If it's not used (I asked in rhev-devel some time ago why do we need it)  - 
> remove it. 
> It's not a virt bug. 
> If you need a newer qemu release,  open a 'depend on qemu release' bug and
> make it depends on the qemu bug.

I'm confused where this BZ belongs, certainly not in RHEVM/qemu-kvm-rhev. Maybe Gerd can make sure this problem is covered by a BZ somewhere. Thanks!
Comment 10 Gerd Hoffmann 2015-11-24 09:27:54 EST
The assert triggered is in spice-server, reassigning.
Comment 11 David Blechter 2015-11-24 10:26:01 EST
To avoid confusion: the reporter opened 2 bugs with exact description. One in spice and the the second ( current one ) landed in spice as well. Closing as dup.

*** This bug has been marked as a duplicate of bug 1281442 ***

Note You need to log in before you can comment on or make changes to this bug.