Bug 1281442 - [qemu-kvm-rhev] Windows 10 VM is shutdown when spice console is opened via spice-html5
[qemu-kvm-rhev] Windows 10 VM is shutdown when spice console is opened via sp...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Pavel Grunt
SPICE QE bug list
:
: 1281438 1317775 1371672 (view as bug list)
Depends On:
Blocks: 1281438
  Show dependency treegraph
 
Reported: 2015-11-12 09:40 EST by Jiri Belka
Modified: 2016-11-03 23:43 EDT (History)
13 users (show)

See Also:
Fixed In Version: spice-0.12.4-17.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output for the vm (4.67 KB, text/plain)
2015-11-12 10:24 EST, Jiri Belka
no flags Details
ovirt-websocket-proxy logs (2.81 KB, application/x-gzip)
2015-11-12 10:53 EST, Jiri Belka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2324 normal SHIPPED_LIVE spice bug fix and enhancement update 2016-11-03 09:43:33 EDT

  None (edit)
Description Jiri Belka 2015-11-12 09:40:11 EST
Description of problem:

Windows 10 VM is shutdown when spice console is opened via spice-html5. IMO opening spice console via whatever way should not cause VM to shutdown at all.

~~~
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name w10 -S -machine pc-i440fx-rhel7.2.0,accel=kvm,usb=off -cpu SandyBridge,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff -m size=2097152k,slots=16,maxmem=20971520k -realtime mlock=off -smp 2,maxcpus=16,sockets=16,cores=1,threads=1 -numa node,nodeid=0,cpus=0-1,mem=2048 -uuid 6b2cddc7-bc08-402b-aa92-df10b47116d8 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=7.2-7.el7,serial=4C4C4544-0058-3410-8058-C2C04F38354A,uuid=6b2cddc7-bc08-402b-aa92-df10b47116d8 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-w10/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2015-11-12T14:22:41,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x5 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x6 -drive file=/rhev/data-center/mnt/10.34.63.204:_home_iso_shared/0c78b4d6-ba00-4d3e-9f9f-65c7d5899d71/images/11111111-1111-1111-1111-111111111111/en_windows_10_enterprise_x86_dvd_6851156.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -drive file=/rhev/data-center/00000001-0001-0001-0001-0000000003e1/2834fba3-6200-489d-9868-7b8c162749ca/images/f59a075c-8442-44d8-8796-766e27452afe/9c5b1fc9-0dbd-4cae-9b02-92deabc22d15,if=none,id=drive-virtio-disk0,format=raw,serial=f59a075c-8442-44d8-8796-766e27452afe,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=2 -netdev tap,fd=29,id=hostnet0,vhost=on,vhostfd=30 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:e7:3f:07,bus=pci.0,addr=0x3,bootindex=3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/6b2cddc7-bc08-402b-aa92-df10b47116d8.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/6b2cddc7-bc08-402b-aa92-df10b47116d8.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=5902,tls-port=5903,addr=10.34.63.223,x509-dir=/etc/pki/vdsm/libvirt-spice,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=33554432,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -msg timestamp=on
2015-11-12T14:22:41.827041Z qemu-kvm: warning: CPU(s) not present in any NUMA nodes: 2 3 4 5 6 7 8 9 10 11 12 13 14 15
2015-11-12T14:22:41.827122Z qemu-kvm: warning: All CPU(s) up to maxcpus should be described in NUMA config
main_channel_link: add main channel client
main_channel_handle_parsed: net test: latency 6.918000 ms, bitrate 74938709 bps (71.467122 Mbps)
((null):16772): Spice-ERROR **: reds.c:1485:reds_send_link_ack: assertion `link->link_mess->channel_type == SPICE_CHANNEL_MAIN' failed
2015-11-12 14:23:11.345+0000: shutting down
~~~

Version-Release number of selected component (if applicable):
spice-html5-0.1.6-2.el6.noarch
rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch
firefox-41.0.2p0

How reproducible:
100%

Steps to Reproduce:
1. boot Windows 10 VM from install iso (I have 32bit version)
2. open spice-html5 console
3. check VM status

Actual results:
VM is down

Expected results:
should be running

Additional info:
- normal (native) spice console of course does _NOT_ causes the VM shutdown
- windows 8.1 64bit is ok via spice-html5 console
Comment 1 Jiri Belka 2015-11-12 09:40:55 EST
spice-html5 console opened via RHEVM 3.6.0.2-0.1.el6
Comment 4 Jiri Belka 2015-11-12 10:24 EST
Created attachment 1093364 [details]
gdb output for the vm
Comment 5 Jiri Belka 2015-11-12 10:44:00 EST
spice-server-0.12.4-15.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.1.x86_64
Comment 6 Jiri Belka 2015-11-12 10:53 EST
Created attachment 1093371 [details]
ovirt-websocket-proxy logs
Comment 7 Pavel Grunt 2015-11-12 15:38:25 EST
Spice-ERROR **: reds.c:1485:reds_send_link_ack: assertion `link->link_mess->channel_type == SPICE_CHANNEL_MAIN' failed

Caused the VM shutdown/crash -> reassigning to spice

Can you attach client debug logs (In javascript console set DEBUG=3) ?

Thanks
Comment 10 Michal Skrivanek 2015-11-14 09:46:57 EST
requesting 7.2.z fix due to severe impact on RHEV 3.6 (and 3.5.z) despite spice-html5 being a tech-preview, unfortunately we can't effectively block it
Comment 15 David Blechter 2015-11-24 10:26:01 EST
*** Bug 1281438 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Fergeau 2016-03-16 08:03:49 EDT
*** Bug 1317775 has been marked as a duplicate of this bug. ***
Comment 17 Mike McCune 2016-03-28 19:16:15 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 19 Tomas Jelinek 2016-08-31 02:23:54 EDT
*** Bug 1371672 has been marked as a duplicate of this bug. ***
Comment 24 errata-xmlrpc 2016-11-03 23:43:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2324.html

Note You need to log in before you can comment on or make changes to this bug.