Bug 1281554 - [abrt] dnf: lib.py:170:package_source_name:AttributeError: 'NoneType' object has no attribute 'rstrip'
[abrt] dnf: lib.py:170:package_source_name:AttributeError: 'NoneType' object ...
Status: CLOSED DUPLICATE of bug 1272936
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e400ef6901bebb0843e4e5fb6e0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 13:56 EST by Till Maas
Modified: 2015-11-18 08:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 08:56:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (228.46 KB, text/plain)
2015-11-12 13:56 EST, Till Maas
no flags Details
File: backtrace (1.44 KB, text/plain)
2015-11-12 13:56 EST, Till Maas
no flags Details
File: dnf-makecache.log (1.91 MB, text/plain)
2015-11-12 13:56 EST, Till Maas
no flags Details

  None (edit)
Description Till Maas 2015-11-12 13:56:34 EST
Description of problem:
I ran dnf builddep loudmouth

Version-Release number of selected component:
dnf-1.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python -OO /bin/dnf builddep loudmouth
executable:     /bin/dnf
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
lib.py:170:package_source_name:AttributeError: 'NoneType' object has no attribute 'rstrip'

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python2.7/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'

Local variables in innermost frame:
package: <hawkey.Package object id 81381, loudmouth-1.4.3-15.fc22.src, fedora-source>

Potential duplicate: bug 1272936
Comment 1 Till Maas 2015-11-12 13:56:41 EST
Created attachment 1093419 [details]
File: _var_log_dnf.log
Comment 2 Till Maas 2015-11-12 13:56:43 EST
Created attachment 1093420 [details]
File: backtrace
Comment 3 Till Maas 2015-11-12 13:56:52 EST
Created attachment 1093421 [details]
File: dnf-makecache.log
Comment 4 Honza Silhan 2015-11-18 08:56:30 EST
We are doing the build for F22 today which should fix this.

*** This bug has been marked as a duplicate of bug 1272936 ***

Note You need to log in before you can comment on or make changes to this bug.