Bug 1281591 - Purge deleted rows from the database
Purge deleted rows from the database
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
medium Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Gorka Eguileor
nlevinki
: ZStream
Depends On:
Blocks: 1281595
  Show dependency treegraph
 
Reported: 2015-11-12 16:26 EST by Sergey Gotliv
Modified: 2016-04-26 14:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1.5-3.el6ost, openstack-cinder-2014.1.5-3.el7ost
Doc Type: Enhancement
Doc Text:
With this update, a new feature adds the ability to clean up rows that are already marked as deleted of a certain specified age. Age is calculated as timedelta from now(), which are given using the command line interface. This removes clutter from the Block Storage database, significantly reduces the database size and improve maintainability of the large deployments.
Story Points: ---
Clone Of:
: 1281595 (view as bug list)
Environment:
Last Closed: 2015-12-22 09:26:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2686 normal SHIPPED_LIVE openstack-cinder bug fix advisory 2015-12-22 14:23:47 EST

  None (edit)
Description Sergey Gotliv 2015-11-12 16:26:36 EST
Description of problem:

Cinder should provide a way to remove "deleted" records from the database. It will allow to significantly reduce a database size and improve maintainability of the large deployments.
Comment 4 errata-xmlrpc 2015-12-22 09:26:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2686.html

Note You need to log in before you can comment on or make changes to this bug.