Bug 1281595 - Purge deleted rows from the database
Purge deleted rows from the database
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
medium Severity medium
: ---
: 6.0 (Juno)
Assigned To: Gorka Eguileor
lkuchlan
: ZStream
Depends On: 1281591
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 16:30 EST by Sergey Gotliv
Modified: 2016-04-26 20:24 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.2.3-11.el7ost
Doc Type: Enhancement
Doc Text:
This update adds the ability to clean up rows that are already marked as deleted of a certain specified age. Age is calculated as timedelta from now() in days, which are specified via the command line. This update removes clutter from the Block Storage service database.
Story Points: ---
Clone Of: 1281591
Environment:
Last Closed: 2016-01-21 08:54:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 lkuchlan 2016-01-04 09:38:10 EST
Verification instructions:
1. Create a volume and delete it
2. Set the system clock +1 day from the current date
3. cinder-manage db purge 1

Results:
The "deleted" entries have removed successfully from Cinder's DB

Tested using:
python-cinder-2014.2.3-11.el7ost.noarch
python-cinderclient-1.1.1-1.el7ost.noarch
openstack-cinder-2014.2.3-11.el7ost.noarch
Comment 4 errata-xmlrpc 2016-01-21 08:54:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0059.html

Note You need to log in before you can comment on or make changes to this bug.