This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283923 - Data Tiering: "ls" count taking link files and promote/demote files into consideration both on fuse and nfs mount
Data Tiering: "ls" count taking link files and promote/demote files into cons...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1275998 1281598
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 05:00 EST by Nithya Balachandran
Modified: 2016-04-19 03:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1281598
Environment:
Last Closed: 2016-04-19 03:49:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-20 05:27:14 EST
REVIEW: http://review.gluster.org/12706 (cluster/tier: readdirp to cold tier only) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-11-23 07:38:01 EST
REVIEW: http://review.gluster.org/12722 (cluster/tier: readdirp to cold tier only) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-11-23 10:49:57 EST
REVIEW: http://review.gluster.org/12722 (cluster/tier: readdirp to cold tier only) posted (#2) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2015-11-24 07:14:03 EST
COMMIT: http://review.gluster.org/12722 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit b8c56ebe617327d570c252f8c411c85a84e727e6
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Wed Nov 4 15:33:22 2015 -0500

    cluster/tier: readdirp to cold tier only
    
    It is possible a file would get migrated in the middle
    of a readdir operation. If there are four subvolumes A,B,C,D,
    and if readdir reads them in order and reaches subvol B,
    then, if a file is moved from D to A, it will not be included
    in the readdir output.
    
    This phenonema has pre-existed in DHT migration but is more
    apparent in tiering.
    
    When a file is moved off the hashed subvolume a T file is created.
    For tiering, we will make the cold subvolume the hashed subvolume.
    This will ensure the creation of a T file. Readdir will not skip T
    files in the tier translator.
    
    Making the cold subvolume the hashed subvolume ensures the T
    files created on promotions or creates will be less likely to
    fill the volume.
    
    Creates still put the data on the hot subvolume.
    
    This is a backport of 12530
    
    > Change-Id: Ifde557d3d0e94a4570ca9f115adee3db2ee75407
    > BUG:  1281598
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-on: http://review.gluster.org/12530
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    
    Conflicts:
    	xlators/cluster/dht/src/tier.c
    
    Change-Id: I5720a4cd04ae5088e5d7d23439b0f90d6bbc6265
    BUG: 1283923
    Reviewed-on: http://review.gluster.org/12722
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Kaushal 2016-04-19 03:49:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.