Bug 128173 - rdist barfs comparing/installing files on hosts with this version of rdist.
rdist barfs comparing/installing files on hosts with this version of rdist.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rdist (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 123931 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 12:45 EDT by Charles C. Figueiredo
Modified: 2015-03-04 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 08:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles C. Figueiredo 2004-07-19 12:45:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461; .NET CLR 1.1.4322)

Description of problem:

I have a script to compare files across netgroups of systems, 
essentially. When my script compares a system's directory to a remote 
directory, it does the following:

rdist -t 120 -M 4 -P /usr/bin/ssh -v -R -f -
ssh other-box -l root rdistd -S

This has worked fine for years, until I installed a recent rdist 
update. If I run this against systems with rdist-6.1.5-30 installed, 
it works fine, if I try running it against the same box, or against 
another box with rdist-6.1.5-34.30.1, I get massive spewage of the 
following errors:
source-box: target-box: REMOTE 
ERROR: /usr/local/oracle/u01/app/oracle/product/8.1.7.3/lib/rdistWaiyB
7 -> libclntsh.so.8.0: symlink failed: File exists

If I initiate this from a 6.1.5-34.30.1 to a 6.1.5-30 it works fine, 
it's only when the target is also -34 that it generates this.

Any idea what's going on?

Thanks,

-charles.

Version-Release number of selected component (if applicable):
rdist-6.1.5-34.30.1

How reproducible:
Always

Steps to Reproduce:
1.ssh other-box -l root rdistd -S
2.rdist -t 120 -M 4 -P /usr/bin/ssh -v -R -f -
3.
    

Actual Results:  Generates a lot of noise.

Expected Results:  It should quietly report as normal.

Additional info:
Comment 1 Phil Knirsch 2004-07-20 05:23:42 EDT
*** Bug 123931 has been marked as a duplicate of this bug. ***
Comment 2 Phil Knirsch 2004-08-03 10:02:06 EDT
Updated and fixed packages have been scheduled for the Red Hat
Enterprise Linux 3 Quarterly Update.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.