Bug 1281825 - 'Failed to start Switch Root' if accented letter in kickstart file
'Failed to start Switch Root' if accented letter in kickstart file
Status: CLOSED DUPLICATE of bug 1280448
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 09:17 EST by Derrien
Modified: 2015-11-13 09:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 09:24:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derrien 2015-11-13 09:17:30 EST
Description of problem:
If there is an accented letter in kickstart file (in a comment for instance)
we get :
[FAILED] Failed to start Switch Root
See 'systemctl status initrd_switch-root.service' for details
Warning: /dev/root does not exist

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Put '# Résumé' in start of a kickstart file
2. Boot with 'append initrd=initrd.img inst.ks=nfs:server:/vol/linux/config/kickstart'
3.

Actual results:


Expected results:


Additional info:
NB : Works with vmlinuz/initrd.img from Fedora22

Extract from /run/initramfs/rdsosreport.txt :

[   24.074714] e8470p dracut-initqueue[665]: File "/sbin/parse-kickstart", line 585, in process_kickstart
[   24.074855] e8470p dracut-initqueue[665]: processed_file = preprocessKickstart(ksfile)
[   24.074993] e8470p dracut-initqueue[665]: File "/usr/lib/python3.4/site-packages/pykickstart/parser.py", line 124, in preprocessKickstart
[   24.075161] e8470p dracut-initqueue[665]: contents = load_to_str(f)
[   24.075295] e8470p dracut-initqueue[665]: File "/usr/lib/python3.4/site-packages/pykickstart/load.py", line 44, in load_to_str
[   24.075426] e8470p dracut-initqueue[665]: return _load_file(location)
[   24.075562] e8470p dracut-initqueue[665]: File "/usr/lib/python3.4/site-packages/pykickstart/load.py", line 93, in _load_file
[   24.075695] e8470p dracut-initqueue[665]: contents = fh.read()
[   24.075827] e8470p dracut-initqueue[665]: File "/usr/lib64/python3.4/encodings/ascii.py", line 26, in decode
[   24.075963] e8470p dracut-initqueue[665]: return codecs.ascii_decode(input, self.errors)[0]
[   24.076122] e8470p dracut-initqueue[665]: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 3: ordinal not in range(128)
[   24.093943] e8470p dracut-initqueue[665]: /lib/anaconda-lib.sh: line 212: /tmp/ks.info: No such file or directory
Comment 1 David Shea 2015-11-13 09:24:30 EST

*** This bug has been marked as a duplicate of bug 1280448 ***

Note You need to log in before you can comment on or make changes to this bug.