Bug 1282099 - Python3 port of python-django-admin-honeypot [NEEDINFO]
Python3 port of python-django-admin-honeypot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-django-admin-honeypot (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eduardo Echeverria
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2015-11-14 17:27 EST by Adolfo Fitoria
Modified: 2016-09-07 06:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-admin-honeypot-1.0.0-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 06:51:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lbalhar: needinfo? (echevemaster)


Attachments (Terms of Use)
Update to 1.0.0 including tests and Python 3 subpackage (4.53 KB, patch)
2016-08-05 10:26 EDT, Jan Beran
no flags Details | Diff
Updated spec file (4.70 KB, patch)
2016-08-17 11:33 EDT, Jan Beran
no flags Details | Diff

  None (edit)
Description Adolfo Fitoria 2015-11-14 17:27:15 EST
Python3 version of python-progressbar is available at pypi 

https://pypi.python.org/pypi/django-admin-honeypot

Please add python3 support.

Thanks.
Comment 1 Petr Viktorin 2016-02-01 07:29:19 EST
Here's a more fleshed out report:

Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 2 Charalampos Stratakis 2016-02-15 10:37:36 EST
Ping?

No response as of yet from maintainer
Comment 3 Jan Kurik 2016-02-24 08:57:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Petr Viktorin 2016-04-19 09:43:56 EDT
Eduardo, do you need some help with updating, or with porting to Python 3?
Comment 5 Jan Beran 2016-08-05 10:26 EDT
Created attachment 1187932 [details]
Update to 1.0.0 including tests and Python 3 subpackage

I have prepared Python 3 patch which includes

- update to version 1.0.0
- source update
- tests are included now
- modernized specfile with Python 3 packaging
- changelog correction to avoid a following error from rpmlint:

$ rpmlint python-django-admin-honeypot.spec
python-django-admin-honeypot.spec: E: specfile-error warning: bogus date in %changelog: Tue Feb 22 2013 Eduardo Echeverria  <echevemaster@gmail.com> - 0.2.4-3
0 packages and 1 specfiles checked; 1 errors, 0 warnings.

The patch follows the recommendation of Matthias (bug #1311552).
Comment 6 Eduardo Echeverria 2016-08-07 01:17:51 EDT
Sorry for  the delay, I'll include your patch. thanks.
Comment 7 Lumír Balhar 2016-08-15 06:51:33 EDT
Hello.

Thank you for new specfile but build fails because there are missing build requires python2-coverage & python2-pytest and python3-coverage & python3-pytest for Python 3 subpackage. Also, more specific python[23]-coverage should be used in test execution command.
Comment 8 Jan Beran 2016-08-17 11:33 EDT
Created attachment 1191667 [details]
Updated spec file

Hi Lumír,

thank you for the review. I attach the spec file, updated according to you guidance.
Comment 9 Lumír Balhar 2016-08-18 03:46:54 EDT
Hello.

Thank you very much for the update. Specfile looks perfect to me now.

If maintainer has nothing against, we can push this changes after a week.

Have a nice day.
Comment 10 Lumír Balhar 2016-08-18 03:48:33 EDT
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15293594

Note You need to log in before you can comment on or make changes to this bug.