Bug 1282141 - python2 subpackage provides python3 binaries
python2 subpackage provides python3 binaries
Status: CLOSED DUPLICATE of bug 1282140
Product: Fedora
Classification: Fedora
Component: python-cclib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 22:13 EST by Eduardo Mayorga
Modified: 2015-11-14 22:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 22:57:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch. (4.70 KB, patch)
2015-11-14 22:14 EST, Eduardo Mayorga
no flags Details | Diff

  None (edit)
Description Eduardo Mayorga 2015-11-14 22:13:23 EST
The version of the Python interpreter in binaries is confusing. Packaging guidelines state: 

If executables are to be shipped for both python 2 and python 3:

    Both python 2 and python 3 variants must provide symlinks with a '-X' and '-X.Y' suffix (python runtime major version, or python runtime major.minor version), unless upstream already provides appropriately versioned executables without the dash.
Comment 1 Eduardo Mayorga 2015-11-14 22:14 EST
Created attachment 1094307 [details]
Proposed patch.
Comment 2 Eduardo Mayorga 2015-11-14 22:57:50 EST

*** This bug has been marked as a duplicate of bug 1282140 ***

Note You need to log in before you can comment on or make changes to this bug.