Bug 1282147 - Pitivi isn't close to stable enough to be included in fedora
Pitivi isn't close to stable enough to be included in fedora
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 23:49 EST by Rodd Clarkson
Modified: 2015-11-22 09:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 09:39:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2015-11-14 23:49:44 EST
Description of problem:

I can't get PiTiVi to run for more than about 1 minute (unless I open it and do nothing).

Importing clips crashes it some times

Trying to move tracks in the time line (which seems impossible, because there's no selection arrow crashes it sometimes.

Just opening it crashes it.

Video editing on Linux is hard enough without including packages that barely start.


Version-Release number of selected component (if applicable):

pitivi-0.94-5.fc23.x86_64


How reproducible:

Use if for about 1 minute.

Steps to Reproduce:
1. Open pitivi
2. Try to do something.
3.

Actual results:

Crashes very quickly


Expected results:

Some sort of stability would be appropriate before packages are included in fedora.


Additional info:
Comment 1 Jean-François Fortin Tam 2015-11-22 09:39:55 EST
Crashes and such are to be reported upstream. Downstream, nobody hears your screams.

The Pitivi folks have been working for an entire year to stabilize the thing amidst all the breakage caused by $insert_dependencies_here (gst, clutter, gtk, wayland, you name it).

0.95 (bug #1283968) should be much better.
Comment 2 Jean-François Fortin Tam 2015-11-22 09:42:13 EST
I should also mention that what ended up packaged downstream somehow behaved differently than upstream (bug #1178168).

Note You need to log in before you can comment on or make changes to this bug.