This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282149 - python-SecretStorage: Please update the spec file with a python2 subpackage [for complete python3 support]
python-SecretStorage: Please update the spec file with a python2 subpackage [...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-SecretStorage (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Charalampos Stratakis
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 1328216
Blocks: PYTHON3 PY3PATCH-REQUESTED 1237384 1282146
  Show dependency treegraph
 
Reported: 2015-11-15 01:23 EST by William Moreno
Modified: 2016-05-23 16:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-SecretStorage-2.1.4-1.fc24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-23 16:03:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Moreno 2015-11-15 01:23:52 EST
Please update the spec file to include a python2 subpackage and use the python-provides macro
Comment 1 Jan Kurik 2016-02-24 08:58:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Fedora Admin XMLRPC Client 2016-02-26 12:51:17 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2016-04-25 16:45:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Dominika Krejčí 2016-05-06 12:12:21 EDT
Hello Raphael,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 5 Raphael Groner 2016-05-06 14:51:00 EDT
Hi Dominika,

I took the package because it was orphaned for some weeks and it's a dependency of backintime where I'm co-maintainer of. Currently, I do not have the time to fix bugs that got assigned to me automatically due to the owner change, could you do that instead? I can give the package to you in PkgDB.
Comment 6 Raphael Groner 2016-05-16 05:47:58 EDT
There was support for python3 with the python3-SecretStorage subpackage since the beginning. This bug is about splitting python2 into its own subpackage according to the common example in python guidelines.
https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 7 Charalampos Stratakis 2016-05-16 07:13:01 EDT
I am preparing a patch for this package to address all the issues. I can get it on pkgdb, but will wait for Dominika to answer first, maybe she would like to maintain it.
Comment 8 Charalampos Stratakis 2016-05-19 11:52:06 EDT
So here is the updated SPEC file:
https://cstratak.fedorapeople.org/python-SecretStorage.spec

And the SRPM:
https://cstratak.fedorapeople.org/python-SecretStorage-2.1.4-1.fc25.src.rpm

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=14171996

The updates also address 1237384 and 1328216 bugzillas. Feel free to review the changes. I will push to rawhide/f24 and maybe f23 if there are no objections by tomorrow.
Comment 9 Raphael Groner 2016-05-19 13:03:03 EDT
> %global pkgname SecretStorage

We should use srcname instead of pkgname. Otherwise, the %python_provide macro can't work correctly.
Comment 10 Charalampos Stratakis 2016-05-20 03:01:39 EDT
You are correct, will fix it.
Comment 12 Fedora Update System 2016-05-20 09:00:49 EDT
python-SecretStorage-2.1.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-36b5949d94
Comment 13 Fedora Update System 2016-05-20 21:31:00 EDT
python-SecretStorage-2.1.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-36b5949d94
Comment 14 Raphael Groner 2016-05-21 04:30:10 EDT
# dnf install python-SecretStorage

installs still 2.1.1-3.fc24, why?

# dnf install python2-SecretStorage

installs 2.1.4-1.fc24

Maybe we miss an Obsoletes: python-SecretStorage < 2.1.4

https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
Comment 15 Charalampos Stratakis 2016-05-23 04:30:15 EDT
The update is still in testing repos. At the moment only the testing repositories (which are enabled by default in the beta image) provide python2-SecretStorage package. When it is pushed to the stable repositories it will (or should) work as intended.
Comment 16 Raphael Groner 2016-05-23 05:17:13 EDT
(In reply to Charalampos Stratakis from comment #15)
> The update is still in testing repos. At the moment only the testing
> repositories (which are enabled by default in the beta image) provide
> python2-SecretStorage package. When it is pushed to the stable repositories
> it will (or should) work as intended.

# dnf install --enablerepo updates-testing python-SecretStorage
→ 2.1.1-3.fc24

Hmm.
Comment 17 Raphael Groner 2016-05-23 05:19:15 EDT
As nothing else than backintime-qt4 is depending, and here it is python3-SecretStorage, it should be okay to go with the fix.
Comment 18 Charalampos Stratakis 2016-05-23 05:37:41 EDT
(In reply to Raphael Groner from comment #16)
> (In reply to Charalampos Stratakis from comment #15)
> > The update is still in testing repos. At the moment only the testing
> > repositories (which are enabled by default in the beta image) provide
> > python2-SecretStorage package. When it is pushed to the stable repositories
> > it will (or should) work as intended.
> 
> # dnf install --enablerepo updates-testing python-SecretStorage
> → 2.1.1-3.fc24
> 
> Hmm.

# dnf install dbus-python #dbus-python is not in updates-testing repos
# dnf install python-SecretStorage --disablerepo=* --enablerepo=updates-testing --refresh

And this should work properly. However if there would be an issue by the time it goes to stable repos about that, it wouldn't be a problem to just add an Obsoletes.
Comment 19 Fedora Update System 2016-05-23 16:03:14 EDT
python-SecretStorage-2.1.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.