Bug 1282146 - Packages with outdated spec (not using %python_provides macro, not python2 subpackages)
Summary: Packages with outdated spec (not using %python_provides macro, not python2 su...
Keywords:
Status: CLOSED DUPLICATE of bug 1285816
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1282044 1282069 1282086 1282140 1282149 1282150 1282151 1282153 1282155 1282156 1282158 1282200 1282225 1282229 1282234 1282235 1282262 1282483 1282487 1282555 1282560 1285544 1285546
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-15 03:29 UTC by William Moreno
Modified: 2017-08-24 09:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-29 13:33:52 UTC


Attachments (Terms of Use)

Description William Moreno 2015-11-15 03:29:21 UTC
As part of:

https://fedoraproject.org/wiki/FAD_Python_3_Porting_2015

I will track here python packages than have out of dates packages and do not provides a python2 subpackage and do not use the python-provides macro.

Comment 1 Francesco Frassinelli (frafra) 2015-11-15 18:25:41 UTC
Why it depends on https://bugzilla.redhat.com/show_bug.cgi?id=1282044 ? This is an application compatible with both Python 2 and Python 3.

Comment 2 Andreas Schneider 2015-11-17 10:01:23 UTC
It would help to get this fixed faster if you have some documentation what to do or if it exists point to it :)

Comment 3 Petr Viktorin 2015-11-20 16:41:03 UTC
Andreas, all the info should be in the Python packaging guidelines: https://fedoraproject.org/wiki/Packaging:Python

I'll belatedly go through the Mass Bug Filing procedure to make this more understandable; in the mean time, if something is unclear, let me know the specifics (e.g. which of the bugs tracked here you need help with).

Comment 4 Andreas Schneider 2015-11-23 08:09:37 UTC
I'm on Fedora 23 and if I try to build a spec with %python_provide macro it fails because it doesn't know the macro.

Also I can't build a test package locally because f23 doesn't know about %{__python3}.

Please make sure packager tools are providing what you are requesting for. I would expect that a "fedpkg mockbuild" for rawhide works on f23 ...

Comment 5 Robert Kuska 2015-11-23 08:16:34 UTC
It seems like you are not BR: python3-devel which is mandatory when building python3 packages.

Comment 6 William Moreno 2015-11-23 15:17:23 UTC
(In reply to Andreas Schneider from comment #4)
> I'm on Fedora 23 and if I try to build a spec with %python_provide macro it
> fails because it doesn't know the macro.
> 
What is the package than you are trying to build with python3?

Comment 7 Petr Viktorin 2015-11-26 14:28:39 UTC
I've created #1285816, which has a better summary -- it's linked to bug filing instructions, rather than the 2015 FAD which is now over.

I plan to migrate the bugs there, then close this as duplicate.

Comment 8 Petr Viktorin 2015-11-26 15:57:23 UTC
portingdb now pulls bug status from bug 1285816

Comment 9 Fedora Admin XMLRPC Client 2016-01-29 13:04:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Petr Viktorin 2016-01-29 13:33:52 UTC
Marking as duplicate of the new bug, which contains the mass filing info.
All open blockers of this bug block the new one as well.

*** This bug has been marked as a duplicate of bug 1285816 ***


Note You need to log in before you can comment on or make changes to this bug.