Bug 1282185 - Keyboard layout switches back to US EN every reboot
Keyboard layout switches back to US EN every reboot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mate-control-center (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 06:12 EST by tom
Modified: 2015-12-13 20:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-13 20:16:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tom 2015-11-15 06:12:41 EST
Description of problem:
Keyboard layout switches back to US-english qwerty after each reboot of Fedora 23.

Version-Release number of selected component (if applicable):
-No idea which component is causing this. 
-My hardware is intel x86_64 desktop, with belgian azerty keyboard. I used mate-compiz fedora 23 live spin to install the system.

How reproducible:
every reboot.

Steps to Reproduce:
1. just reboot and every change made through mate-menu (system-preferences-keyboard) is gone.
2.
3.

Actual results:
US-qwerty keymap

Expected results:
be-latin1 belgian azerty KEYMAP.

Additional info:
- I used the mate-compiz spin to install my system
- I checked the content of /etc/vconsole.conf (it is correct after reboot : KEYMAP=be-latin1) but I still get the wrong layout
- the locale (preferred language) is US-english, is also OK in 'locale.conf'
- when I manually correct, I use system>preferences>keyboard, it shows 'belgian' layout. I then have to add another 'belgian' layout and remove the first one. Then it remains OK for the rest of the session until next reboot.
- when I try with 'Authentication' via System>Administration>keyboard I get an error : "Could not launch 'Keyboard' " failed to execute child process "xterm" (no such file or directory)
Comment 1 Vitezslav Crhonek 2015-11-18 04:02:28 EST
It seems you're talking about keyboard layouts in graphical mode (X Window), not text mode (virtual console), right?
Comment 2 tom 2015-11-23 15:40:05 EST
I completely reinstalled Fedora 23 with a different version : standard workstation instead of the Mate-Compiz spin, added belgian be-latin1 keyboard as preference during installation and the keyboard layout is perfectly OK when I log in.

From a terminal window in Gnome 3 I next installed:
> dnf groupinstall mate-compiz
> dnf groupinstall mate-applications
logged out of gnome 3 and logged back into the new Mate environment and the keyboard layout was wrong again. (without rebooting). 

This is clearly a bug in the Mate-Compiz Fedora 23 setup. 

I was advised through fedoraforum.org to report it as a bug and am hoping for a solution, because I really would like to get Mate environment working in the new Fedora 23 release.

see also : http://forums.fedoraforum.org/showthread.php?t=307735&goto=newpost

Tom.
Comment 3 Vitezslav Crhonek 2015-11-24 03:36:39 EST
I got it, this issue has very likely nothing to do with keyboard in text console (kbd). Reassigning to mate-control-center component - I'm not sure whether it's correct one, but it's definitely closer.
Comment 4 Wolfgang Ulbrich 2015-11-24 09:27:08 EST
Well, the default us keyboard layout is something what i delete in every installation first, i need only one layout :)
But i can't reproduce it if us and german layout is used by mate-keyboard-properties.

What shows
[rave@mother ~]$ gsettings get org.mate.peripherals-keyboard-xkb.kbd layouts
['de\tnodeadkeys']
after you choose the belgian layout?

Here was another report about https://bugzilla.redhat.com/show_bug.cgi?id=1279074#c6
Can you try this?

Btw, for using system-config-keyboard which sets the layout in general (not only for mate session) you need to install xterm.
Comment 5 tom 2015-11-24 10:19:19 EST
I get the following, but the keyboard layout is OK now.
[tom@localhost ~]$ gsettings get org.mate.peripherals-keyboard-xkb.kbd layouts
['be']
[tom@localhost ~]$ 

The only difference is that I rebooted. Yesterday I thought by just logging out of gnome3 and back into the new installed mate-desktop, that the keyboard layout was wrong again, but turns out I should have rebooted first. 
I also did a 'locale --no-convert set-keymap be-latin1' as suggested on above fedora forum, but I think the layout was already OK after the reboot.

There was definitely something unusual the first time I logged into the newly installed mate-desktop, which resulted in the wrong layout at first, but apparently it kept the layout change to be-latin1 after rebooting. 

My conclusion : first installing F23 workstation with default gnome3, and then adding the mate-desktop packages is a valid workaround for the keyboard layout issue in the F23 Mate-Compiz spin.
Comment 6 Wolfgang Ulbrich 2015-11-24 11:01:31 EST
I don't think it makes a different if you install first gnome or not.
It's more like in https://bugzilla.redhat.com/show_bug.cgi?id=1279074#c6 described.
Removing and re-adding the us layout fixes the issue.
The packages what you see on mate-live-spin are the same as in f22.
There are no differents beside from f23 label.
So, i think that something set the gsettings key back to default after reboot in f23.
The state of the gsettings key after reboot would have been my next question :)
Good for you that you can't answer the question anymore ;)

Well, i will leave the report a while open to see if another users run in this issue.

Note You need to log in before you can comment on or make changes to this bug.