Bug 1282215 - new version released
new version released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mujs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 10:38 EST by Pablo Rodríguez
Modified: 2015-12-07 15:10 EST (History)
1 user (show)

See Also:
Fixed In Version: mujs-0-1.20150929git0827611.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 10:36:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Rodríguez 2015-11-15 10:38:45 EST
Petr,

although maybe not strictly required (sorry, but I’m not sure about this), mujs has been updated with some fixes (http://git.ghostscript.com/?p=mujs.git;a=summary).

Would it be possible to have the updated version in koji?

Many thanks for your help,

Pablo
Comment 1 Petr Šabata 2015-11-16 04:40:30 EST
Hi Pablo,

sure, I'll take a look.

Thanks.
Comment 2 Petr Šabata 2015-11-16 10:36:23 EST
Okay, updated in Rawhide.
Let me know if you need the update in a stable branch, too.
Comment 3 Pablo Rodríguez 2015-11-16 13:59:41 EST
Petr,

I wonder whether it would be possible that you add the Python bindings to mupdf, PyMuPDF (https://github.com/rk700/PyMuPDF).

Release for 1.8 is almost finished, although it needs some polishing.

BTW, could you take a look at bug #1280518? The package has a maintainer and I don’t know what the etiquette prescribes here.

mupdf includes a patch named in the spec file %{name}-%{version}openjpeg.patch. If the spec (and the file itself) had the file name updated to %{name}-openjpeg.patch and the patch is named accordingly, the compilation problem from each new version would disappear.

I have already explained this to the maintainer, but all he has done is to update the version number from patch file name. Could you take a look at this?

Many thanks for your help,

Pablo
Comment 4 Petr Šabata 2015-11-18 05:01:35 EST
(In reply to Pablo Rodríguez from comment #3)
> Petr,
> 
> I wonder whether it would be possible that you add the Python bindings to
> mupdf, PyMuPDF (https://github.com/rk700/PyMuPDF).
> 
> Release for 1.8 is almost finished, although it needs some polishing.

I don't maintain any Python packages, I am not familiar with their guidelines, and since I don't speak Python, I don't feel like maintaining this one.

You can add it to the wishlist [0] and hope for the best.  Or even better, become a Fedora packager [1] and maintain it yourself! :)

> BTW, could you take a look at bug #1280518? The package has a maintainer and
> I don’t know what the etiquette prescribes here.

Just be patient; ping him from time to time if necessary.
 
> mupdf includes a patch named in the spec file
> %{name}-%{version}openjpeg.patch. If the spec (and the file itself) had the
> file name updated to %{name}-openjpeg.patch and the patch is named
> accordingly, the compilation problem from each new version would disappear.
> 
> I have already explained this to the maintainer, but all he has done is to
> update the version number from patch file name. Could you take a look at
> this?

I'll remove the %{version} macro from the Patch line but I'll leave the update to Pavel.

[0] https://fedoraproject.org/wiki/WishList
[1] https://fedoraproject.org/wiki/Join_the_package_collection_maintainers?rd=PackageMaintainers/Join
Comment 5 Pablo Rodríguez 2015-12-07 05:08:54 EST
(In reply to Petr Šabata from comment #4)
> (In reply to Pablo Rodríguez from comment #3)
> > 
> > I wonder whether it would be possible that you add the Python bindings to
> > mupdf, PyMuPDF (https://github.com/rk700/PyMuPDF).
> > 
> > Release for 1.8 is almost finished, although it needs some polishing.
> 
> I don't maintain any Python packages, I am not familiar with their
> guidelines, and since I don't speak Python, I don't feel like maintaining
> this one.

Sorry for the delayed reply, Petr I’m afraid I missed your message.

> You can add it to the wishlist [0] and hope for the best.  Or even better,
> become a Fedora packager [1] and maintain it yourself! :)

I don’t code, so I’m afraid I shouldn’t maintain any package (Python-based or not :-().
Comment 6 Petr Šabata 2015-12-07 12:02:58 EST
You can always learn :)
Comment 7 Pablo Rodríguez 2015-12-07 15:10:15 EST
(In reply to Petr Šabata from comment #6)
> You can always learn :)

But at that point is when I remember that Fedora requires my personal phone number for that kind of cooperation.

It is really a pity, but I cannot start thinking of other kind of contributions than bug reporting to Fedora if an email address is not enough.

Note You need to log in before you can comment on or make changes to this bug.