Bug 1282220 - Missing dependencies - python3-PyYAML
Missing dependencies - python3-PyYAML
Status: CLOSED DUPLICATE of bug 1277715
Product: Fedora
Classification: Fedora
Component: python-journal-brief (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 11:03 EST by Rabin
Modified: 2015-11-16 04:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 04:02:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rabin 2015-11-15 11:03:15 EST
Description of problem:

the package `journal-brief` is missing the above dependencies


Version-Release number of selected component (if applicable):


journal-brief-1.1.1-1.fc23.noarch.rpm

How reproducible:
every time

Steps to Reproduce:

# dnf install journal-brief
# journal-brief --help

Traceback (most recent call last):
  File "/usr/bin/journal-brief", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'PyYAML' distribution was not found and is required by journal-brief



Actual results:


Expected results:


Additional info:

dnf install python3-PyYAML will solve the problem.
Comment 1 Tim Waugh 2015-11-16 04:02:01 EST

*** This bug has been marked as a duplicate of bug 1277715 ***

Note You need to log in before you can comment on or make changes to this bug.