Bug 1282250 - RFE: don't consider remove operations as successful transactions
RFE: don't consider remove operations as successful transactions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1290263 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 14:29 EST by Marco Motta
Modified: 2016-01-04 14:53 EST (History)
6 users (show)

See Also:
Fixed In Version: dnf-1.1.5-1.fc23 dnf-1.1.5-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 16:59:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Motta 2015-11-15 14:29:00 EST
How reproducible:

From Fedora 23:
# dnf distro-sync --releasever 22 --allowerasing
(download of many GB of rpm)
Effect: package xxx conflict with yyy
...
(I am in a tty, and cannot scroll video)
# dnf remove yyy
# dnf distro-sync --releasever 22 --allowerasing
(download of many GB of rpm, for the same rpm!!!!)
Effect: package xxx2 conflict with yyy2
...
and again, and again...

Version-Release number of selected component (if applicable):

dnf-1.1.3-1.fc23.noarch

Expected results:

rpm already downloaded must be used for the second execution of the same command, when I want install the same package that failed the first time.
Comment 1 Honza Silhan 2015-11-18 09:08:14 EST
We can exclude `autoremove`, `remove` + operations without RPM transaction (`info`, `list`, ...) to not be considered to keepcache=0 transaction fail caching feature [1].

[1] http://dnf.readthedocs.org/en/latest/conf_ref.html?highlight=keepcache#main-options
Comment 2 Honza Silhan 2015-12-14 07:30:02 EST
*** Bug 1290263 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2015-12-18 12:47:17 EST
dnf-plugins-core-0.1.15-1.fc23 dnf-1.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 4 Fedora Update System 2015-12-18 12:48:54 EST
dnf-plugins-core-0.1.15-1.fc22 dnf-1.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 5 Fedora Update System 2015-12-19 14:59:45 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 6 Fedora Update System 2015-12-22 10:35:26 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 7 Fedora Update System 2015-12-22 16:58:59 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-01-04 14:52:17 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.