Bug 1290263 - dnf system-upgrade repeats full download does not check existing download in some cases
dnf system-upgrade repeats full download does not check existing download in ...
Status: CLOSED DUPLICATE of bug 1282250
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 18:44 EST by John Floyd
Modified: 2015-12-14 07:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 07:30:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Floyd 2015-12-09 18:44:50 EST
Description of problem:
system-upgrade
dnf does not check downloads from previous run IF you have cleaned up a package that causes an error.  It does a full download again.  Maybe one or 2 packages skipped but everything else is downloaded again.

Note it does check previous downloads IF you just run the program again without making any changes.

problem has occuured at home nad work on completely different systems.


Version-Release number of selected component (if applicable):


How reproducible:

do system-upgrade download

delete a package on the current system (ewith dnf)

do another system-upgrade download


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Always check if needed files are already there...


Additional info:
Comment 1 Honza Silhan 2015-12-14 07:30:02 EST
PR: https://github.com/rpm-software-management/dnf/pull/388

*** This bug has been marked as a duplicate of bug 1282250 ***

Note You need to log in before you can comment on or make changes to this bug.