Bug 1282251 - Failed to rebuild against python-3.5
Failed to rebuild against python-3.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-defusedxml (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1282263
  Show dependency treegraph
 
Reported: 2015-11-15 14:32 EST by Ralph Bean
Modified: 2015-11-17 13:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 15:09:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix FTBFS and modernize python macros (3.45 KB, patch)
2015-11-15 14:50 EST, Ralph Bean
no flags Details | Diff

  None (edit)
Description Ralph Bean 2015-11-15 14:32:58 EST
See the build here:  http://koji.fedoraproject.org/koji/taskinfo?taskID=11794010

This is problematic because python3-openid depends on python3-defusedxml and python3-fedora depends on python3-openid, and lots of things depend on python3-fedora.

It looks like python-defusedxml is simply using the unittest API in some way that changed in the latest python release -- i.e., it is not a defect of the module, but only a defect in the test suite.

Disabling the test suite short-term could get things moving again until we can find out more.
Comment 1 Ralph Bean 2015-11-15 14:50 EST
Created attachment 1094580 [details]
Fix FTBFS and modernize python macros

This should unblock python3-openid which should unblock python3-fedora, etc..
Comment 2 Ralph Bean 2015-11-15 15:09:36 EST
Built here:  http://koji.fedoraproject.org/koji/buildinfo?buildID=699506
Comment 3 Miro Hrončok 2015-11-17 13:35:28 EST
Thanks

Note You need to log in before you can comment on or make changes to this bug.