Bug 1282263 - [PATCH] python3-openid FTBFS in rawhide
[PATCH] python3-openid FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python3-openid (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Dorňák
Fedora Extras Quality Assurance
:
Depends On: 1282251
Blocks: 1282265 1282774
  Show dependency treegraph
 
Reported: 2015-11-15 16:31 EST by Ralph Bean
Modified: 2016-11-30 19:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:37:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to the latest upstream. (7.45 KB, application/mbox)
2015-11-15 16:31 EST, Ralph Bean
no flags Details

  None (edit)
Description Ralph Bean 2015-11-15 16:31:59 EST
Created attachment 1094615 [details]
Update to the latest upstream.

python3-openid fails to build from source in rawhide.  The issue is an ImportError from of a deprecated stdlib exception.

The issue is fixed in the latest upstream release:  https://github.com/necaris/python3-openid/pull/15

I've attached a patch to the spec file here.  It would be a simple version update, but the patch originally applied in the spec file broke, so, instead of rebasing it, I removed it and replaced it with a sed statement in the prep section.  This should be less fragile in the face of future releases.  The patch here also adds some new deps for expanded tests in the check section.

Scratch build with this applied:
http://koji.fedoraproject.org/koji/taskinfo?taskID=11855665
Comment 1 Patrick Uiterwijk 2015-11-17 06:29:40 EST
Note that I particularly like the "fragileness" of a patch instead of sed.
The reason for that is that that means that whatever patch you have needs to be explicitly rebased when you update, and as such the chance that you leave old, no longer needed, patches in is pretty much non-existent.
Comment 2 Ralph Bean 2015-11-17 09:11:16 EST
That's reasonable, Patrick.  I won't rebase my patch with that though but will instead just let the maintainer(s) apply it or change it as they prefer.
Comment 3 Adam Williamson 2015-11-18 13:45:18 EST
It would be fairly easy to add a 'test' before the sed which would fail if no files contained "/usr/bin/env python", and have that cause the build to fail with a message saying 'you can take the sed out now'.
Comment 4 Adam Williamson 2015-11-18 14:02:58 EST
Also, the packager somehow did a 3.0.6 build that worked, so this isn't FTBFS any more.
Comment 5 Jakub Dorňák 2015-11-19 06:31:55 EST
Hi, I apologize. First I saw that it needs to be rebuilt with Python-3.5, so I checked https://github.com/necaris/python3-openid/ and built 3.0.6 (unfortunately the latest tag in git).
Later I found this bug and realized that there are newer tarballs on https://pypi.python.org/pypi/python3-openid/.

P. S. I've taken the ease of sed and added fragility of diff. §;o)

Note You need to log in before you can comment on or make changes to this bug.