Bug 1282296 - Missing dependency on fontawesome-fonts-web
Missing dependency on fontawesome-fonts-web
Status: CLOSED DUPLICATE of bug 1282297
Product: Fedora EPEL
Classification: Fedora
Component: python-sphinx_rtd_theme (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Piotr Popieluch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 23:01 EST by David Moreau Simard
Modified: 2015-11-16 14:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 14:51:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Moreau Simard 2015-11-15 23:01:45 EST
I noticed an issue when building a package against EL7 with EPEL, as shown here: https://copr-be.cloud.fedoraproject.org/results/dmsimard/python-cicoclient/epel-7-x86_64/00139672-python-cicoclient/build.log.gz

====
Exception occurred:
  File "/usr/lib64/python2.7/shutil.py", line 208, in copytree
    raise Error, errors
Error: [('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff', '/builddir/build/BUILD/python-cicoclient-0.3.3/html/_static/fonts/fontawesome-webfont.woff', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff'"), ('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg', '/builddir/build/BUILD/python-cicoclient-0.3.3/html/_static/fonts/fontawesome-webfont.svg', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg'")]
====

Indeed, when installing python-sphinx_rtd_theme, the directory tree looks like this:
====
# tree /usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/
/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/
├── fontawesome-webfont.eot
├── fontawesome-webfont.svg -> /usr/share/fonts/fontawesome/fontawesome-webfont.svg
├── fontawesome-webfont.ttf -> /usr/share/fonts/fontawesome/fontawesome-webfont.ttf
├── fontawesome-webfont.woff -> /usr/share/fonts/fontawesome/fontawesome-webfont.woff
├── Inconsolata-Bold.ttf
├── Inconsolata.ttf
├── Lato-Bold.ttf -> /usr/share/fonts/lato/Lato-Bold.ttf
├── Lato-Regular.ttf -> /usr/share/fonts/lato/Lato-Regular.ttf
├── RobotoSlab-Bold.ttf
└── RobotoSlab-Regular.ttf
====

Notice the symoblic links to /usr/share/font/fontawesome/*.

These fonts are provided by the fontawesome-fonts-web package but it was not installed when installing python-sphinx_rtd_theme. It looks like we need to add a dependency.

I noticed the same issue on the fedora 22 and fedora 23 package of python-sphinx_rtd_theme.
Comment 1 Piotr Popieluch 2015-11-16 14:51:12 EST

*** This bug has been marked as a duplicate of bug 1282297 ***

Note You need to log in before you can comment on or make changes to this bug.