Bug 1282297 - Missing dependency on fontawesome-fonts-web
Missing dependency on fontawesome-fonts-web
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-sphinx_rtd_theme (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Piotr Popieluch
Fedora Extras Quality Assurance
: Reopened
: 1282296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 23:02 EST by David Moreau Simard
Modified: 2016-03-02 21:24 EST (History)
2 users (show)

See Also:
Fixed In Version: python-sphinx_rtd_theme-0.1.8-4.fc22 python-sphinx_rtd_theme-0.1.8-4.fc21 python-sphinx_rtd_theme-0.1.9-1.fc23 python-sphinx_rtd_theme-0.1.8-4.el7 python-sphinx_rtd_theme-0.1.8-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 21:24:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Moreau Simard 2015-11-15 23:02:19 EST
I noticed an issue when building a package against EL7 with EPEL, as shown here: https://copr-be.cloud.fedoraproject.org/results/dmsimard/python-cicoclient/epel-7-x86_64/00139672-python-cicoclient/build.log.gz

====
Exception occurred:
  File "/usr/lib64/python2.7/shutil.py", line 208, in copytree
    raise Error, errors
Error: [('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff', '/builddir/build/BUILD/python-cicoclient-0.3.3/html/_static/fonts/fontawesome-webfont.woff', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff'"), ('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg', '/builddir/build/BUILD/python-cicoclient-0.3.3/html/_static/fonts/fontawesome-webfont.svg', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg'")]
====

Indeed, when installing python-sphinx_rtd_theme, the directory tree looks like this:
====
# tree /usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/
/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/
├── fontawesome-webfont.eot
├── fontawesome-webfont.svg -> /usr/share/fonts/fontawesome/fontawesome-webfont.svg
├── fontawesome-webfont.ttf -> /usr/share/fonts/fontawesome/fontawesome-webfont.ttf
├── fontawesome-webfont.woff -> /usr/share/fonts/fontawesome/fontawesome-webfont.woff
├── Inconsolata-Bold.ttf
├── Inconsolata.ttf
├── Lato-Bold.ttf -> /usr/share/fonts/lato/Lato-Bold.ttf
├── Lato-Regular.ttf -> /usr/share/fonts/lato/Lato-Regular.ttf
├── RobotoSlab-Bold.ttf
└── RobotoSlab-Regular.ttf
====

Notice the symoblic links to /usr/share/font/fontawesome/*.

These fonts are provided by the fontawesome-fonts-web package but it was not installed when installing python-sphinx_rtd_theme. It looks like we need to add a dependency.

I noticed the same issue on the fedora 22 and fedora 23 package of python-sphinx_rtd_theme.
Comment 1 Piotr Popieluch 2015-11-16 14:51:12 EST
*** Bug 1282296 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2015-11-16 16:29:30 EST
python-sphinx_rtd_theme-0.1.8-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-dd12b1ea21
Comment 3 Fedora Update System 2015-11-16 16:29:46 EST
python-sphinx_rtd_theme-0.1.8-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b0ff7b5a79
Comment 4 Fedora Update System 2015-11-16 16:30:00 EST
python-sphinx_rtd_theme-0.1.8-4.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-85f7050ad4
Comment 5 Fedora Update System 2015-11-16 16:30:11 EST
python-sphinx_rtd_theme-0.1.8-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-38b386c2a1
Comment 6 Fedora Update System 2015-11-16 16:30:21 EST
python-sphinx_rtd_theme-0.1.8-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f7f062def8
Comment 7 Fedora Update System 2015-11-17 20:20:32 EST
python-sphinx_rtd_theme-0.1.8-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-38b386c2a1
Comment 8 Fedora Update System 2015-11-18 11:51:50 EST
python-sphinx_rtd_theme-0.1.8-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-dd12b1ea21
Comment 9 Fedora Update System 2015-11-18 17:18:56 EST
python-sphinx_rtd_theme-0.1.8-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f7f062def8
Comment 10 Fedora Update System 2015-11-18 19:22:40 EST
python-sphinx_rtd_theme-0.1.8-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b0ff7b5a79
Comment 11 Fedora Update System 2015-11-20 19:51:03 EST
python-sphinx_rtd_theme-0.1.8-4.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-85f7050ad4
Comment 12 Fedora Update System 2015-11-24 12:16:55 EST
python-sphinx_rtd_theme-0.1.9-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7907f44c30
Comment 13 Fedora Update System 2015-11-24 21:53:15 EST
python-sphinx_rtd_theme-0.1.9-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-sphinx_rtd_theme'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7907f44c30
Comment 14 Fedora Update System 2015-11-30 18:24:57 EST
python-sphinx_rtd_theme-0.1.8-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-11-30 18:50:54 EST
python-sphinx_rtd_theme-0.1.8-4.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-12-02 16:50:26 EST
python-sphinx_rtd_theme-0.1.9-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-12-02 22:59:53 EST
python-sphinx_rtd_theme-0.1.8-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2016-02-09 08:16:54 EST
python-sphinx_rtd_theme-0.1.8-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f7f062def8
Comment 19 Fedora Update System 2016-02-10 12:20:30 EST
python-sphinx_rtd_theme-0.1.8-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f7f062def8
Comment 20 Fedora Update System 2016-03-02 21:24:44 EST
python-sphinx_rtd_theme-0.1.8-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.