Bug 1282314 - vinagre does not connect
vinagre does not connect
Status: CLOSED DUPLICATE of bug 1281600
Product: Fedora
Classification: Fedora
Component: vinagre (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 23:35 EST by David Gibson
Modified: 2015-11-16 05:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 05:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace if vinagre run failing to connect (54.78 KB, application/x-gzip)
2015-11-15 23:37 EST, David Gibson
no flags Details

  None (edit)
Description David Gibson 2015-11-15 23:35:04 EST
Description of problem:

Whenever I attempt to connect to a VNC server with vinagre, it says "connection closed" and proceeds no further, although other tools are able to connect to the vnc server fine.

Version-Release number of selected component (if applicable):

vinagre-3.18.1-1.fc23.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Establish a vnc server (I used port 5911 + a manually established ssh tunnel)
2. Launch vinagre
3. Attempt to connect

Actual results:

Dialog appears saying "Connection to host [localhost:5911] was closed."

Expected results:

Connects and displays VNC.

Additional info:

An strace indicates that vinagre is never even attempting a connect() call to the vnc server.
Comment 1 David Gibson 2015-11-15 23:37 EST
Created attachment 1094726 [details]
strace if vinagre run failing to connect

strace log from the following:

  1. Run "strace -o vinagre1.strace -f vinagre"
  2. Attempt to connect to a server
  3. Quit vinagre.

Below shows that no connection is attempted to the actual vnc server:

$ zgrep connect vinagre1.strace.gz 
3510  connect(5, {sa_family=AF_LOCAL, sun_path=@"/tmp/dbus-qckhtt6YQn"}, 23) = 0
3510  connect(9, {sa_family=AF_LOCAL, sun_path="/run/user/1000/wayland-0"}, 27 <unfinished ...>
3510  <... connect resumed> )           = -1 ENOENT (No such file or directory)
3510  connect(8, {sa_family=AF_LOCAL, sun_path=@"/tmp/.X11-unix/X0"}, 20 <unfinished ...>
3510  <... connect resumed> )           = 0
3510  connect(9, {sa_family=AF_LOCAL, sun_path=@"/tmp/.X11-unix/X0"}, 20) = 0
3510  connect(9, {sa_family=AF_LOCAL, sun_path=@"/tmp/dbus-D9ljXClF5h"}, 23) = 0
3510  connect(13, {sa_family=AF_LOCAL, sun_path="/run/dbus/system_bus_socket"}, 29) = 0
3510  connect(13, {sa_family=AF_LOCAL, sun_path=@"/tmp/dbus-qckhtt6YQn"}, 23) = 0
3516  connect(15, {sa_family=AF_LOCAL, sun_path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory)
3516  connect(14, {sa_family=AF_LOCAL, sun_path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory)
3516  connect(14, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("127.0.0.1")}, 16) = 0
3516  connect(14, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("127.0.0.1")}, 16) = 0
3516  connect(14, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("127.0.0.1")}, 16) = 0
Comment 2 David King 2015-11-16 05:36:37 EST

*** This bug has been marked as a duplicate of bug 1281600 ***

Note You need to log in before you can comment on or make changes to this bug.