Bug 1282324 - powerdevil 5.4.3-1 prevents kded5 from starting
powerdevil 5.4.3-1 prevents kded5 from starting
Status: CLOSED DUPLICATE of bug 1282261
Product: Fedora
Classification: Fedora
Component: powerdevil (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 01:10 EST by larsh
Modified: 2015-11-17 09:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 09:59:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description larsh 2015-11-16 01:10:41 EST
Description of problem:
After the upgrade to powerdevil 5.4.3-1, kded5 will no longer start.

This has all kinds of other effects. The most prominent for me was that kmix goes into an endless loop upon starting, because kded wasn't started.
Volume and brightness controls also stopped working.

I eventually tracked it down to the new version of powerdevil.
After a downgrade to powerdevil-5.3.0-1 everything is fine again.

Version-Release number of selected component (if applicable):
5.4.3-1

How reproducible:
always

Steps to Reproduce:
1. simply start KDE
2. notice kded5 is not running
3. logs in .xsession-errors indicate a shared library version issue with powerdevil (see below)

Actual results:
kde5 not running

Expected results:
kde5 running

Additional info:
The root of the problem is this (from .xsession-errors):
kded5 [kdeinit5]: symbol lookup error: /lib64/libpowerdevilcore.so.2: undefined symbol: _ZNK11QMetaObject10Connection18isConnected_helperEv
Comment 1 larsh 2015-11-16 01:12:54 EST
Above should read:

Actual results:
kded5 not running

Expected results:
kded5 running
Comment 2 Jonathan Wakely 2015-11-17 07:57:11 EST
dup of Bug 1282261 and Bug 1282594
Comment 3 Rex Dieter 2015-11-17 09:59:07 EST
Thanks

*** This bug has been marked as a duplicate of bug 1282261 ***

Note You need to log in before you can comment on or make changes to this bug.