Bug 1282594 - /lib64/libpowerdevilcore.so.2: undefined symbol
/lib64/libpowerdevilcore.so.2: undefined symbol
Status: CLOSED DUPLICATE of bug 1282261
Product: Fedora
Classification: Fedora
Component: powerdevil (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 15:32 EST by Nick Strugnell
Modified: 2015-11-17 09:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 09:58:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2015-11-16 15:32:15 EST
Description of problem:

After latest update, kded5 was constantly respawning. I tracked this down to an error in powerdevil. kded5 trace is:

kded5: symbol lookup error: /lib64/libpowerdevilcore.so.2: undefined symbol: _ZNK11QMetaObject10Connection18isConnected_helperEv



Version-Release number of selected component (if applicable):

powerdevil-5.4.3-1.fc22.x86_64
kf5-kded-5.15.0-1.fc22.x86_64

How reproducible:

always.


Steps to Reproduce:
1. Enable power management in Plasma
2. 
3.

Actual results:
kded5 constantly respawns and important system services such as NetworkManager and kdewallet are unavailable.


Expected results:
kded5 should run as normal.


Additional info:
Workaround:
cd /usr/share/kservices5/kded ; mv powerdevil.desktop powerdevil.desktop-disabled ; reboot
Comment 1 Jonathan Wakely 2015-11-17 07:56:07 EST
seems to be a dup of Bug 1282261 and Bug 1282324
Comment 2 Rex Dieter 2015-11-17 09:58:57 EST
Thanks!

*** This bug has been marked as a duplicate of bug 1282261 ***

Note You need to log in before you can comment on or make changes to this bug.