Bug 1282372 - Multicast does not work over IPv6
Multicast does not work over IPv6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jan Friesse
cluster-qe@redhat.com
: ZStream
Depends On:
Blocks: 1283066 1283067
  Show dependency treegraph
 
Reported: 2015-11-16 04:04 EST by Christine Caulfield
Modified: 2016-11-04 02:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: corosync-2.3.6-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1283066 1283067 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:48:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to move the bind() so that ipV6 works (1.39 KB, patch)
2015-11-16 04:05 EST, Christine Caulfield
no flags Details | Diff

  None (edit)
Description Christine Caulfield 2015-11-16 04:04:10 EST
Description of problem:
Multicast does not work over IPv6

corosync 2.3.5 but I suspect this goes back some way

How reproducible:
Every time

Steps to Reproduce:
1. Set up a cluster to use IPv6 multicast
2. Start nodes

Actual results:
The nodes do not see each other. corosync-quorumtool shows that all the
nodes are isolated

Expected results:
Cluster should form correctly.

Additional info:
This is specific to IPv6, IPv4 clusters are not affected. Also IPv6 clusters using updu are also fine.

Here is my corosync.conf for testing. The other node has IP address
ending in :2 of course.

totem {
    version: 2
    secauth: off
    cluster_name: small
    transport: udp
    interface {
        ringnumber:   0
	mcastaddr:    ff08::2
	bindnetaddr:  2001:db8:1:0:200:11ff:fecc:1
	ttl: 8
    }
    ip_version: ipv6
    nodeid: 1
}

quorum {
    provider: corosync_votequorum
    expected_votes: 2
}
Comment 2 Christine Caulfield 2015-11-16 04:05 EST
Created attachment 1094783 [details]
Patch to move the bind() so that ipV6 works

I've also tested that this patch does not break IPv4.
Comment 6 Mike McCune 2016-03-28 18:46:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 errata-xmlrpc 2016-11-04 02:48:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2463.html

Note You need to log in before you can comment on or make changes to this bug.