Bug 1283067 - Multicast does not work over IPv6
Multicast does not work over IPv6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jan Friesse
cluster-qe@redhat.com
: ZStream
Depends On: 1282372
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 02:27 EST by Jan Kurik
Modified: 2015-12-08 05:28 EST (History)
7 users (show)

See Also:
Fixed In Version: corosync-2.3.4-7.el7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282372
Environment:
Last Closed: 2015-12-08 05:28:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
7.2.z-bz1283067-1-totemudp-Move-udp-bind-so-that-multicast-works-with- (2.01 KB, patch)
2015-11-18 10:48 EST, Jan Friesse
no flags Details | Diff

  None (edit)
Description Jan Kurik 2015-11-18 02:27:28 EST
This bug has been copied from bug #1282372 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 3 Jan Friesse 2015-11-18 10:48:02 EST
Created attachment 1096139 [details]
7.2.z-bz1283067-1-totemudp-Move-udp-bind-so-that-multicast-works-with-

totemudp: Move udp bind() so that multicast works with IPv6

It seems that the IPv6 multicast parameters only take effect when bind()
is called, so I've moved the mcast recv socket bind() to the bottom of
totemudp_build_sockets_ip().

Signed-off-by: Christine Caulfield <ccaulfie@redhat.com>
Reviewed-by: Jan Friesse <jfriesse@redhat.com>
Comment 7 errata-xmlrpc 2015-12-08 05:28:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2568.html

Note You need to log in before you can comment on or make changes to this bug.