Bug 1282461 - [upgrade] Error messages seen in glusterd logs, while upgrading from RHGS 2.1.6 to RHGS 3.1
[upgrade] Error messages seen in glusterd logs, while upgrading from RHGS 2.1...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1247515
Blocks: 1216951 1287597
  Show dependency treegraph
 
Reported: 2015-11-16 08:48 EST by hari gowtham
Modified: 2016-06-16 09:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1247515
: 1287597 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:44:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-16 08:49:51 EST
REVIEW: http://review.gluster.org/12587 (Removing error message in glusterd log shown during upgrade) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-11-24 00:11:42 EST
REVIEW: http://review.gluster.org/12587 (glusterd:Removing error message in glusterd log during upgrade) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-11-26 04:23:05 EST
REVIEW: http://review.gluster.org/12587 (glusterd:Removing error message in glusterd log during upgrade) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-11-26 05:42:37 EST
REVIEW: http://review.gluster.org/12587 (glusterd:Removing error message in glusterd log during upgrade) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2015-12-02 01:51:50 EST
REVIEW: http://review.gluster.org/12587 (glusterd:Removing error message in glusterd log during upgrade) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2015-12-02 02:17:09 EST
REVIEW: http://review.gluster.org/12587 (glusterd:Removing error message in glusterd log during upgrade) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Vijay Bellur 2015-12-02 05:25:40 EST
COMMIT: http://review.gluster.org/12587 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 905b3d26a794510892f6a9b51139bc9cfd947c02
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Nov 24 10:31:35 2015 +0530

    glusterd:Removing error message in glusterd log during upgrade
    
    when one of the gluster node is upgraded to 3.7 from a lower
    version and a mixed cluster is formed, tier related error
    messages are displayed in the glusterd log which are removed
    
    Change-Id: I8d0fc43ce049990a6a52306317ea1298a0a91390
    BUG: 1282461
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12587
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 8 Mike McCune 2016-03-28 18:40:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Niels de Vos 2016-06-16 09:44:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.