Bug 1287597 - [upgrade] Error messages seen in glusterd logs, while upgrading from RHGS 2.1.6 to RHGS 3.1
[upgrade] Error messages seen in glusterd logs, while upgrading from RHGS 2.1...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1247515 1282461
Blocks: 1216951
  Show dependency treegraph
 
Reported: 2015-12-02 07:12 EST by hari gowtham
Modified: 2016-04-19 03:49 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282461
Environment:
Last Closed: 2016-04-19 03:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-02 07:14:26 EST
REVIEW: http://review.gluster.org/12851 (glusterd:Removing error message in glusterd log during upgrade) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-12-03 04:15:13 EST
REVIEW: http://review.gluster.org/12851 (glusterd:Removing error message in glusterd log during upgrade) posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-12-08 00:19:16 EST
REVIEW: http://review.gluster.org/12851 (glusterd:Removing error message in glusterd log during upgrade) posted (#3) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-12-09 06:53:07 EST
COMMIT: http://review.gluster.org/12851 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 10d2b90770a09b283c7141c3c422a6349c0c30b4
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Nov 24 10:31:35 2015 +0530

    glusterd:Removing error message in glusterd log during upgrade
    
            back port of : http://review.gluster.org/#/c/12766/
    
    when one of the gluster node is upgraded to 3.7 from a lower
    version and a mixed cluster is formed, tier related error
    messages are displayed in the glusterd log which are removed
    
    >Change-Id: I8d0fc43ce049990a6a52306317ea1298a0a91390
    >BUG: 1282461
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: http://review.gluster.org/12587
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: Id4df935795e145c5d98350b67b5a9d94419df558
    BUG: 1287597
    Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12851
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 5 Mike McCune 2016-03-28 18:40:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Kaushal 2016-04-19 03:49:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.