Bug 1282560 - python-bitmath: Update with python3 support
python-bitmath: Update with python3 support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-bitmath (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Bielawa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 1282146
  Show dependency treegraph
 
Reported: 2015-11-16 13:09 EST by William Moreno
Modified: 2016-01-31 20:53 EST (History)
2 users (show)

See Also:
Fixed In Version: python-bitmath-1.3.0-2.fc22 python-bitmath-1.3.0-2.fc23 python-bitmath-1.3.0-2.el7 python-bitmath-1.3.0-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 22:20:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Moreno 2015-11-16 13:09:02 EST
Please update to the latest release and enable python3 support as part of the move of Fedora to python3.
Comment 1 Tim Bielawa 2015-11-16 13:22:13 EST
ACK.

Can you point out a reference procedure for guidance?

Or a link to a recently updated spec file which made this update successfully?

Thanks!
Comment 2 Tim Bielawa 2015-11-16 13:24:53 EST
Actually I take that back. I just went through the referenced 'blocked' issue #1282146 and picked out a package that has been crossed out.

All I could really use now is some verification instructions so I can make the required changes and verify the result is what you are expecting.
Comment 3 Petr Viktorin 2015-11-20 06:12:01 EST
I'd be happy to look over the changes. Can you point me to a scratch build or the updated spec?
Comment 4 Tim Bielawa 2016-01-10 14:54:53 EST
I'm having mixed results here trying to add all the new macros, I'd appreciate any help you can offer with fixing the failing builds.

Working and producing dual RPMs:

* rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=12492985
* f23: http://koji.fedoraproject.org/koji/taskinfo?taskID=12493035
* f22: http://koji.fedoraproject.org/koji/taskinfo?taskID=12493039

Failing builds:

* el6: http://koji.fedoraproject.org/koji/taskinfo?taskID=12493042
* epel7: http://koji.fedoraproject.org/koji/taskinfo?taskID=12493045
Comment 5 Petr Viktorin 2016-01-11 07:22:18 EST
The el6 build fails because upstream tests are not compatible with Python 2.6. I've noted this on the relevant Github commit [0]. Let me know how important this is (are you planning a rebase in EL6?).

For EL7 the problem is some missing `%if 0%{?with_python3}` guards and some missing macros. I've updated the spec and built successfully in COPR [1], you can get the spec from the SRPM there [2].

Hope that helps; let me know if I can help further.


[0] https://github.com/tbielawa/bitmath/commit/973202b3b55fa9e8a089c1feb4db65ccc24fac35#diff-65b926d8fd225683358cc3415edf1accL49
[1] https://copr.fedoraproject.org/coprs/pviktori/python-bitmath/build/152723/
[2] https://copr-be.cloud.fedoraproject.org/results/pviktori/python-bitmath/epel-7-x86_64/00152723-python-bitmath/
Comment 6 Tim Bielawa 2016-01-11 14:40:11 EST
That's great, thanks a bunch Petr. I'll try another scratch build after $day_job with the updated spec file and the old-style "with nested" context managers :-)
Comment 7 Fedora Update System 2016-01-14 15:59:12 EST
python-bitmath-1.3.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5e346df704
Comment 8 Fedora Update System 2016-01-14 15:59:13 EST
python-bitmath-1.3.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-b31115a23e
Comment 9 Fedora Update System 2016-01-14 15:59:18 EST
python-bitmath-1.3.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-88091010e3
Comment 10 Fedora Update System 2016-01-14 15:59:19 EST
python-bitmath-1.3.0-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-9248e2dacb
Comment 11 Fedora Update System 2016-01-15 03:55:00 EST
python-bitmath-1.3.0-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-9248e2dacb
Comment 12 Fedora Update System 2016-01-15 04:22:45 EST
python-bitmath-1.3.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-b31115a23e
Comment 13 Fedora Update System 2016-01-15 13:52:53 EST
python-bitmath-1.3.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-88091010e3
Comment 14 Fedora Update System 2016-01-16 14:25:48 EST
python-bitmath-1.3.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5e346df704
Comment 15 Fedora Update System 2016-01-25 22:20:07 EST
python-bitmath-1.3.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-01-26 13:28:06 EST
python-bitmath-1.3.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Tim Bielawa 2016-01-29 10:07:38 EST
@petr, thanks for all your assistance with this so far, you've been super helpful :-)

Can you tell me if this is expected behavior?

Say I have python-bitmath-1.2.3-3.fc23.1 installed on my laptop. This is the last update pushed through bodhi before the update we built in this BZ, python-bitmath-1.3.0-2.

Now, the new 1.3.0-2 release has made it's way through testing and is now in F23 stable updates [0]. This package actually yields two sub-packages, python2-bitmath and python3-bitmath.

With the new macros we've added to the spec [1] (specifically the 'provides' ones) users can do a simple 'dnf update python-bitmath' and they will receive the new python2-bitmath package:

> [root@deepfryer ~]# dnf update python-bitmath
> ...
>  Package                Arch          Version          Repository      Size
> ============================================================================
> Installing:
>  python2-bitmath        noarch        1.3.0-2.fc23     updates         78 k
>      replacing  python-bitmath.noarch 1.2.3-3.fc23.1
> 
> Transaction Summary

This seems like OK behavior to me. What I'm not sure about now is if the following example is what should be happening:

Say that we don't have 'python-bitmath' installed right now. My, perhaps incorrect, understanding was that the new macros we've added would add some kind of 'obsoletes' hook if a user attempted to install the old version.

Expected behavior:

If python-bitmath-1.2.3-3.fc23.1 isn't installed, and a user runs 'dnf install python-bitmath', they would be prompted to install python2-bitmath-1.3.0-2.fc23 instead (because it should obsolete the old version)

Observed behavior:

'dnf install python-bitmath' prompts the user to install 'python-bitmath-1.2.3-3.fc23.1' instead.


Am I simply wrong about the actual expected behavior and this is working as expected?



[0] https://bodhi.fedoraproject.org/updates/?packages=python-bitmath
[1] http://pkgs.fedoraproject.org/cgit/rpms/python-bitmath.git/tree/python-bitmath.spec
Comment 18 Tim Bielawa 2016-01-29 10:18:29 EST
Hm, I just discovered that this may not be a real issue. If ``python-bitmath`` is installed and the user later runs 'dnf update' then the package will be updated to the new version (at least on f23).
Comment 19 Fedora Update System 2016-01-29 13:53:04 EST
python-bitmath-1.3.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2016-01-31 20:53:33 EST
python-bitmath-1.3.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.