Bug 1282580 - rhel-osp-director: 8.0 - No replacement for ahc-match tool is available.
rhel-osp-director: 8.0 - No replacement for ahc-match tool is available.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-inspector (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Dmitry Tantsur
Alexander Chuzhoy
:
: 1301865 (view as bug list)
Depends On:
Blocks: 1290377 1307001
  Show dependency treegraph
 
Reported: 2015-11-16 14:19 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:42 EDT (History)
12 users (show)

See Also:
Fixed In Version: python-tripleoclient-0.1.1-4.el7ost openstack-ironic-python-agent-1.1.0-2.el7ost openstack-ironic-inspector-2.2.4-2.el7ost
Doc Type: Enhancement
Doc Text:
The director includes new functionality to allow automatic profile matching. Users can specify automatic matching between nodes and deployment roles based on data available from the introspection step. Users now use ironic-inspector introspection rules and new python-tripleoclient commands to assign profiles to nodes.
Story Points: ---
Clone Of:
: 1307001 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 250405 None None None Never
OpenStack gerrit 257867 None None None 2015-12-22 12:09 EST
OpenStack gerrit 287734 None None None 2016-03-03 06:36 EST

  None (edit)
Description Alexander Chuzhoy 2015-11-16 14:19:13 EST
rhel-osp-director: 8.0 - No ahc-match tool available.


Environment:
instack-undercloud-2.1.3-1.el7ost.noarch
openstack-ironic-inspector-2.2.2-1.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
openstack-ironic-conductor-4.2.0-2.1.el7ost.noarch
openstack-ironic-common-4.2.0-2.1.el7ost.noarch
openstack-ironic-api-4.2.0-2.1.el7ost.noarch
python-ironic-inspector-client-1.2.0-4.el7ost.noarch



Need to be able to match/assign nodes to different roles (i.e. controller, compute,ceph, etc) based on their HW specs, and the ahc-match tool used before isn't avaiable now.
Comment 2 Jaromir Coufal 2015-12-07 13:50:06 EST
Was ahc-match tool replaced or is it still supposed to be part of the process?
Comment 3 Dmitry Tantsur 2015-12-08 03:54:09 EST
I'm in process of writing support code in python-tripleoclient. For now nothing exists in OSPd8 due to tripleo moved upstream and ahc-match staying downstream (and unmaintained).
Comment 4 Dmitry Tantsur 2015-12-22 12:09:07 EST
Attaching link to the documentation patch to describe the new workflow.
Comment 5 Mike Burns 2016-01-26 05:02:48 EST
*** Bug 1301865 has been marked as a duplicate of this bug. ***
Comment 7 Dmitry Tantsur 2016-02-24 07:03:02 EST
Please follow http://tripleo.org/advanced_deployment/profile_matching.html to test this feature. Note that additional data from the python-hardware library is NOT available yet. I think a separate bug should be filed for it.
Comment 9 Alexander Chuzhoy 2016-03-02 17:15:25 EST
FailedQA:
Environment:
openstack-ironic-inspector-2.2.4-2.el7ost.noarch
python-tripleoclient-0.1.1-4.el7ost.noarch
openstack-ironic-inspector
openstack-ironic-conductor-4.2.2-4.el7ost.noarch
openstack-ironic-inspector-2.2.4-2.el7ost.noarch
openstack-ironic-common-4.2.2-4.el7ost.noarch
python-ironic-inspector-client-1.2.0-6.el7ost.noarch
python-tripleoclient-0.1.1-4.el7ost.noarch
openstack-ironic-api-4.2.2-4.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch

Following the guide - the following commands trown a message and exit with error.

[stack@undercloud72 ~]$  openstack overcloud profiles list
'function' object has no attribute 'node'
[stack@undercloud72 ~]$ openstack overcloud profiles match --control-flavor control --control-scale 1 --compute-flavor compute --compute-scale 1
'function' object has no attribute 'node'

The guide says:
"This command should exit without errors (and optionally without warnings)."
Comment 10 Dmitry Tantsur 2016-03-03 06:20:09 EST
Please provide the output of these commands with --debug flag
Comment 11 Dmitry Tantsur 2016-03-03 06:36:07 EST
Nevermind, I've figured it out. Bad backport.
Comment 12 Alexander Chuzhoy 2016-03-18 11:12:45 EDT
Verified:
Environment:
python-tripleoclient-0.2.0-1.el7ost.noarch
openstack-ironic-inspector-2.2.4-3.el7ost.noarch
openstack-ironic-conductor-4.2.2-4.el7ost.noarch
python-ironic-inspector-client-1.2.0-6.el7ost.noarch
openstack-ironic-common-4.2.2-4.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
openstack-ironic-api-4.2.2-4.el7ost.noarch

Was able to assign profiles using this procedure:
http://tripleo.org/advanced_deployment/profile_matching.html
Comment 14 errata-xmlrpc 2016-04-07 17:42:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.