Bug 1282606 - VMware VM folder containing '/' is incorrectly displayed
VMware VM folder containing '/' is incorrectly displayed
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Alex Newman
ui:explorer
: ZStream
Depends On:
Blocks: 1298689
  Show dependency treegraph
 
Reported: 2015-11-16 16:17 EST by Alex Newman
Modified: 2016-06-29 11:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298689 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:08:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'/' shown as '%2f' (67.66 KB, image/png)
2015-11-16 16:17 EST, Alex Newman
no flags Details

  None (edit)
Description Alex Newman 2015-11-16 16:17:07 EST
Created attachment 1095091 [details]
'/' shown as '%2f'

Description of problem:
VMware VM folder containing '/' is incorrectly displayed. '/' displayed as %2F

Version-Release number of selected component (if applicable):
5.5.0.10-beta2.1.20151110134042_d6f5459 

How reproducible:
Very

Steps to Reproduce:
1.Create VM folder with '/' in the name in vSphere
2.Add provider to CF app
3.View said folder

Actual results:


Expected results:


Additional info:
Comment 2 Harpreet Kataria 2015-11-25 14:25:56 EST
Alex,

I was not able to recreate this on latest codebase, i tried that on both Firefox & chrome. Can you retest with latest build, if you still see the issue, please provide access to your appliance where i can see this happening to further troubleshoot the issue. See attached screenshot from my environment with a folder name with '/' in the name.

Thanks,
~Harpreet
Comment 6 Harpreet Kataria 2016-01-11 17:16:19 EST
https://github.com/ManageIQ/manageiq/pull/6140
Comment 7 CFME Bot 2016-01-14 13:36:14 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/3ae65782c10872fe17ac450a497ce2e87c58a741

commit 3ae65782c10872fe17ac450a497ce2e87c58a741
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 11 17:04:47 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 11 17:04:47 2016 -0500

    unescape special characters in tree test/tooltip & right cell headers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282606

 app/presenters/explorer_presenter.rb      |  2 +-
 app/presenters/tree_node_builder.rb       |  4 ++--
 app/views/layouts/_content.html.haml      |  2 +-
 spec/presenters/tree_node_builder_spec.rb | 30 ++++++++++++++++++++++++------
 4 files changed, 28 insertions(+), 10 deletions(-)
Comment 8 CFME Bot 2016-01-14 18:33:10 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d8a21464e9573bc7c991bba2696c30196d577377

commit d8a21464e9573bc7c991bba2696c30196d577377
Merge: 6d50210 2775645
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 14 18:23:12 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 14 18:23:12 2016 -0500

    Merge branch '55z_pr_6140' into '5.5.z'
    
    unescape special characters in tree test/tooltip & right cell headers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282606
    https://bugzilla.redhat.com/show_bug.cgi?id=1298689
    (cherry picked from commit 3ae6578)
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6140
    
    See merge request !716

 app/presenters/explorer_presenter.rb      |  2 +-
 app/presenters/tree_node_builder.rb       |  4 ++--
 app/views/layouts/_content.html.haml      |  2 +-
 spec/presenters/tree_node_builder_spec.rb | 30 ++++++++++++++++++++++++------
 4 files changed, 28 insertions(+), 10 deletions(-)
Comment 9 CFME Bot 2016-01-14 18:33:18 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=27756456f4ecadf925546a128351360b2df85f56

commit 27756456f4ecadf925546a128351360b2df85f56
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 11 17:04:47 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 14 13:12:15 2016 -0500

    unescape special characters in tree test/tooltip & right cell headers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282606
    https://bugzilla.redhat.com/show_bug.cgi?id=1298689
    (cherry picked from commit 3ae6578)

 app/presenters/explorer_presenter.rb      |  2 +-
 app/presenters/tree_node_builder.rb       |  4 ++--
 app/views/layouts/_content.html.haml      |  2 +-
 spec/presenters/tree_node_builder_spec.rb | 30 ++++++++++++++++++++++++------
 4 files changed, 28 insertions(+), 10 deletions(-)
Comment 11 CFME Bot 2016-01-19 22:41:48 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 12 Alex Newman 2016-04-22 17:22:48 EDT
5.6.0.4-beta2.3.20160421172650_719e256
Comment 14 errata-xmlrpc 2016-06-29 11:08:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.