Bug 1282652 - Please update virt-viewer included with RHEV
Please update virt-viewer included with RHEV
Status: CLOSED DUPLICATE of bug 1181289
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.6.0
All Windows
unspecified Severity medium
: ---
: ---
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
spice, easyfix
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 19:17 EST by Marcus West
Modified: 2015-11-17 04:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 04:54:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2052293 None None None Never

  None (edit)
Description Marcus West 2015-11-16 19:17:35 EST
Description of problem:

Please update virt-viewer included with RHEV

We use the MS Windows spice client (virt-viewer) and have observed some minor problems with it.

These include:
  * occasional rescaling problems when resizing or switching to full-screen
  * key combinations lost  (Windows + arrow has no response in the client window)
  * keys "stuck" (shift locked on, until clicking back in to windows then back in to the spice client window)
  * screen saver activating minutes after user has already unlocked the screen and been interacting with a client

I recently checked and two major versions of the client (virt-viewer) have been released since the current version supplied with RHEV (in package rhevm-spice-client-x64-msi-3.5-3.el6.noarch).  The latest major release (2.0) has been available since January 12, 2015 - almost 11 months ago.

This latest version includes fixes for memory leaks, misc crash fixes (security update?) and other helpful fixes.

Is there any reason why the version supplied through the RHN (in the rhevm-spice-client-x64-msi package) is more than two major releases, and two years old?
If not could the packaged version please be tested and updated?


Version-Release number of selected component (if applicable):

rhevm-spice-client-x64-msi-3.5-3.el6.noarch
VirtViewer 0.6.0-34 (64-bit)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I should add that we're also regularly seeing problems with the clipboard between the virt-viewer and Windows 7.  The problems don't happen often, perhaps once a day, but when they happen they can prevent copying and pasting text in either direction (from the VM or two the VM).

Again, I'm sure I've seen that the newer releases of virt-viewer include fixes for bugs of this type.
Comment 1 Uri Lublin 2015-11-17 04:54:49 EST

*** This bug has been marked as a duplicate of bug 1181289 ***

Note You need to log in before you can comment on or make changes to this bug.