Bug 1282746 - Swift's proxy-server is not configured to use ceilometer
Swift's proxy-server is not configured to use ceilometer
Status: CLOSED UPSTREAM
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
All Linux
medium Severity medium
: ---
: trunk
Assigned To: Javier Peña
Shai Revivo
: Automation, Triaged
Depends On:
Blocks: 1296899
  Show dependency treegraph
 
Reported: 2015-11-17 05:17 EST by Daniel Mellado
Modified: 2017-06-18 09:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296899 (view as bug list)
Environment:
Last Closed: 2017-06-18 09:45:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 316147 None None None 2016-05-18 12:04 EDT

  None (edit)
Description Daniel Mellado 2015-11-17 05:17:04 EST
Description of problem:

The /etc/swift/proxy-server.conf generated by the installer doesn't take into consideration the object storage service for telemetry, thus there's no ceilometer support for swift.

After configuring it manually as the install guide states (http://docs.openstack.org/icehouse/install-guide/install/yum/content/ceilometer-install-swift.html) it refuses to start   


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install packstack
2. Run tempest.scenario.test_object_storage_telemetry_middleware.TestObjectStorageTelemetry
3. It'll fail due to swift nor configured to use ceilometer

Actual results:

Swift is not producing notifications using ceilometer. Manual attemps to fix it break swift-proxy. This is making tempest.scenario.test_object_storage_telemetry_middleware.TestObjectStorageTelemetry fail

Expected results:

To get ceilometer notifications from swift and the test passing.

Additional info:
Comment 3 Javier Peña 2016-05-18 12:04:51 EDT
https://review.openstack.org/316147 includes a proposed change that fixes this.
Comment 4 Christopher Brown 2017-06-18 09:45:49 EDT
Change was merged.

Note You need to log in before you can comment on or make changes to this bug.