Bug 1296899 - Swift's proxy-server is not configured to use ceilometer
Swift's proxy-server is not configured to use ceilometer
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
All Linux
unspecified Severity medium
: ---
: trunk
Assigned To: Alfredo Moralejo
Shai Revivo
: Automation
Depends On: 1282746
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 06:25 EST by Daniel Mellado
Modified: 2016-09-27 06:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-8.0.0-0.20160526215136.644d86f.el7.centos.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282746
Environment:
Last Closed: 2016-09-27 06:21:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 316147 None None None 2016-05-20 13:09 EDT

  None (edit)
Description Daniel Mellado 2016-01-08 06:25:03 EST
+++ This bug was initially created as a clone of Bug #1282746 +++

Description of problem:

The /etc/swift/proxy-server.conf generated by the installer doesn't take into consideration the object storage service for telemetry, thus there's no ceilometer support for swift.

After configuring it manually as the install guide states (http://docs.openstack.org/icehouse/install-guide/install/yum/content/ceilometer-install-swift.html) it refuses to start   


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install packstack
2. Run tempest.scenario.test_object_storage_telemetry_middleware.TestObjectStorageTelemetry
3. It'll fail due to swift nor configured to use ceilometer

Actual results:

Swift is not producing notifications using ceilometer. Manual attemps to fix it break swift-proxy. This is making tempest.scenario.test_object_storage_telemetry_middleware.TestObjectStorageTelemetry fail

Expected results:

To get ceilometer notifications from swift and the test passing.

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-17 05:17:07 EST ---

Since this issue was entered in bugzilla without a release flag set, rhos-8.0? has been automatically added to ensure that it is properly evaluated for this release.
Comment 3 Alfredo Moralejo 2016-05-19 10:26:04 EDT
This is being fixed on https://review.openstack.org/#/c/316147/.
Comment 4 Alfredo Moralejo 2016-06-15 03:59:55 EDT
Patch has been merged in packstack and packaged since version openstack-packstack-8.0.0-0.20160526215136.644d86f.el7.centos.noarch.rpm.

Note You need to log in before you can comment on or make changes to this bug.